summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-devtools/python/python3-pytest-reverse_1.0.1.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-09-02 16:24:39 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-09-03 16:02:41 +0000
commit72e884bc11ac69de9491620fa8b32cee928e05ba (patch)
treea0568d93737ae9ce274a59685c46cfdd266ae2f8 /meta-agl-profile-core/recipes-devtools/python/python3-pytest-reverse_1.0.1.bb
parent6976dc76c4bfaed7ec519c8d0d8c9d39396c9469 (diff)
meta-agl-profile-core: add pyagl to agl-devel images
Changes: - Add recipe for pyagl, and add it as a dependency of packagegroup-agl-core-devel. - Add recipes for pyagl dependencies python3-asyncssh, python3-pytest-dependency, and python3-pytest-reverse. The intent is to get these into upstream meta-python so these local copies can be dropped when they're available from there. Bug-AGL: SPEC-3562 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I876ef2fffbe8724aadb23170e1ed196f05132f89 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25176 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-core/recipes-devtools/python/python3-pytest-reverse_1.0.1.bb')
-rw-r--r--meta-agl-profile-core/recipes-devtools/python/python3-pytest-reverse_1.0.1.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-devtools/python/python3-pytest-reverse_1.0.1.bb b/meta-agl-profile-core/recipes-devtools/python/python3-pytest-reverse_1.0.1.bb
new file mode 100644
index 000000000..5ed9b1d9d
--- /dev/null
+++ b/meta-agl-profile-core/recipes-devtools/python/python3-pytest-reverse_1.0.1.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "pytest-reverse is a pytest plugin to reverse test order"
+HOMEPAGE = "https://github.com/adamchainz/pytest-reverse"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=caf1f407ae86ecd57ab721dff94079b7"
+
+SRC_URI[sha256sum] = "40cbc47df8a262fed778e500f4d0b17d2d08ef8b9fbf899c0bab9488be192aac"
+
+inherit pypi setuptools3
+
+DEPENDS += "${PYTHON_PN}-pytest-native"
+
+BBCLASSEXTEND = "native"