summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-multimedia/pulseaudio/agl-audio-plugin_0.1.bb
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-16 22:14:52 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-20 17:07:06 +0200
commitbb0882c5dad030f676e424265ebcd869bb3ff899 (patch)
treed95bb2d7ad6b5ac47427f73babe015b0ade02342 /meta-agl-profile-core/recipes-multimedia/pulseaudio/agl-audio-plugin_0.1.bb
parent97e5e76efa44f55ee9aaf3998bb3df38b829706c (diff)
Introduce meta-agl-profile-core and meta-agl-profile-graphics
Rework towards agl profiles. This change is part of a series of changes to create the AGL profiles. This set will mainly introduce the 'core' profile. It is setup to be a drop-in change, thus some files were kept in (dummy) locations for now. However, they'll be taken care of in the next changes in this series. The main target of the meta-agl-profile-core layer is to host: - a minimal, bootable image with network and package management enabled -- agl-image-boot - a minimal image with network and packagemanagement and the AGL APIs -- agl-image-minimal The layer meta-agl-profile-graphical is used as superset of these and includes support for egl+wayland+weston. All recipes concerning graphics were moved there. This is not a full profile as we still have to migrate some parts of meta-agl-demo in a follow-up changeset. The roadmap as discussed during the F2F session in Karlsruhe is: - week 16 : core profile and profiles w/o graphics - week 17 : graphical profiles - week 18 : final conversion of the demo image v2: moved agl-login-manager from -graphics to -core (see Jose's comment) v3: moved back after discussion - follow-up in separate changeset Change-Id: Idacb0d1274baac1f63f8d1b850d4b1104ac33918 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-core/recipes-multimedia/pulseaudio/agl-audio-plugin_0.1.bb')
-rw-r--r--meta-agl-profile-core/recipes-multimedia/pulseaudio/agl-audio-plugin_0.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-multimedia/pulseaudio/agl-audio-plugin_0.1.bb b/meta-agl-profile-core/recipes-multimedia/pulseaudio/agl-audio-plugin_0.1.bb
new file mode 100644
index 000000000..633a3e248
--- /dev/null
+++ b/meta-agl-profile-core/recipes-multimedia/pulseaudio/agl-audio-plugin_0.1.bb
@@ -0,0 +1,28 @@
+SUMMARY = "AGL Audio Policy Plugin"
+DESCRIPTION = "AGL PulseAudio Routing plugin, forked from the Tizen IVI \
+PulseAudio Routing plugin, also known as module-murphy-ivi. This is a \
+stripped-down version of the former, not needing Murphy anymore and using \
+either a JSON configuration file or its own embedded configuration."
+HOMEPAGE = "http://www.iot.bzh"
+
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
+
+DEPENDS = "json-c pulseaudio"
+RDEPENDS_${PN} = "pulseaudio-server pulseaudio-module-null-sink pulseaudio-module-loopback"
+
+SRCREV = "952d404e87ca6001e546fe9105bdb6760c468760"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/agl-audio-plugin;protocol=https;branch=${AGL_BRANCH}"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+FULL_OPTIMIZATION = "-O1 -pipe ${DEBUG_FLAGS}"
+
+PULSE_PV="9.0"
+
+EXTRA_OECMAKE_append = " -DPULSE_PV:STRING=${PULSE_PV}"
+
+FILES_${PN} += "${libdir}/pulse-${PULSE_PV}/modules/* ${sysconfdir}/pulse/*"
+FILES_${PN}-dbg += "${libdir}/pulse-${PULSE_PV}/modules/.debug/*"