summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-support
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2019-02-12 16:24:25 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2019-02-28 16:59:52 +0100
commit99ce725c6857e5022243ef63a1365e303566c3fd (patch)
treebd9177459bcbc52ec98a56d5b7ca82bf928d31a0 /meta-agl-profile-core/recipes-support
parent6a89e444a26a854e482b39b50d04f8e16aa01744 (diff)
libmicrohttpd: Upgrade to version 0.9.63
The libmicrohttpd includes the patch since its version 0.9.60. So putting the recipe for libmicrohttpd here in wait of an upgrade in poky is perfect. Change-Id: I1dcfad7c3d56be7f9fdff36f6dd5c008c5939076 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'meta-agl-profile-core/recipes-support')
-rw-r--r--meta-agl-profile-core/recipes-support/libmicrohttpd/files/0001-Enable-using-epoll-without-listen-socket_0.9.55.patch31
-rw-r--r--meta-agl-profile-core/recipes-support/libmicrohttpd/libmicrohttpd_0.9.55.bbappend2
-rw-r--r--meta-agl-profile-core/recipes-support/libmicrohttpd/libmicrohttpd_0.9.63.bb28
3 files changed, 28 insertions, 33 deletions
diff --git a/meta-agl-profile-core/recipes-support/libmicrohttpd/files/0001-Enable-using-epoll-without-listen-socket_0.9.55.patch b/meta-agl-profile-core/recipes-support/libmicrohttpd/files/0001-Enable-using-epoll-without-listen-socket_0.9.55.patch
deleted file mode 100644
index 4e807f8f7..000000000
--- a/meta-agl-profile-core/recipes-support/libmicrohttpd/files/0001-Enable-using-epoll-without-listen-socket_0.9.55.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 5a410caefa1cb0337c8c1457a7619549829fe129 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Jos=C3=A9=20Bollo?= <jose.bollo@iot.bzh>
-Date: Mon, 5 Nov 2018 15:37:53 +0100
-Subject: [PATCH] Enable using epoll() without listen socket.
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Change-Id: Iadcb7fa936bf193987f098e6d8b5815456765a85
-Signed-off-by: José Bollo <jose.bollo@iot.bzh>
----
- src/microhttpd/daemon.c | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/src/microhttpd/daemon.c b/src/microhttpd/daemon.c
-index 71a0ce0b..018e7289 100644
---- a/src/microhttpd/daemon.c
-+++ b/src/microhttpd/daemon.c
-@@ -5914,8 +5914,7 @@ MHD_start_daemon_va (unsigned int flags,
-
- #ifdef EPOLL_SUPPORT
- if ( (0 != (*pflags & MHD_USE_EPOLL)) &&
-- (0 == daemon->worker_pool_size) &&
-- (0 == (*pflags & MHD_USE_NO_LISTEN_SOCKET)) )
-+ (0 == daemon->worker_pool_size) )
- {
- if (0 != (*pflags & MHD_USE_THREAD_PER_CONNECTION))
- {
---
-2.17.2
-
diff --git a/meta-agl-profile-core/recipes-support/libmicrohttpd/libmicrohttpd_0.9.55.bbappend b/meta-agl-profile-core/recipes-support/libmicrohttpd/libmicrohttpd_0.9.55.bbappend
deleted file mode 100644
index f7bde04b4..000000000
--- a/meta-agl-profile-core/recipes-support/libmicrohttpd/libmicrohttpd_0.9.55.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI_append = " file://0001-Enable-using-epoll-without-listen-socket_${PV}.patch"
diff --git a/meta-agl-profile-core/recipes-support/libmicrohttpd/libmicrohttpd_0.9.63.bb b/meta-agl-profile-core/recipes-support/libmicrohttpd/libmicrohttpd_0.9.63.bb
new file mode 100644
index 000000000..ab6f681de
--- /dev/null
+++ b/meta-agl-profile-core/recipes-support/libmicrohttpd/libmicrohttpd_0.9.63.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
+HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
+LICENSE = "LGPL-2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=9331186f4f80db7da0e724bdd6554ee5"
+SECTION = "net"
+DEPENDS = "file"
+
+SRC_URI = "http://ftp.gnu.org/gnu/libmicrohttpd/${BPN}-${PV}.tar.gz"
+SRC_URI[md5sum] = "1c10de049608fca46941cbc790e3ab00"
+SRC_URI[sha256sum] = "37c36f1be177f0e37ef181a645cd3baac1000bd322a01c2eff70f3cc8c91749c"
+
+inherit autotools lib_package pkgconfig gettext
+
+CFLAGS += "-pthread -D_REENTRANT"
+
+EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../"
+
+PACKAGECONFIG ?= "curl https"
+PACKAGECONFIG_append_class-target = "\
+ ${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)} \
+"
+PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
+PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
+PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls,"
+
+do_compile_append() {
+ sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
+}