summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-test/blobsallad/blobsallad/0001-Makefile.patch
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-16 22:14:52 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-20 17:07:06 +0200
commitbb0882c5dad030f676e424265ebcd869bb3ff899 (patch)
treed95bb2d7ad6b5ac47427f73babe015b0ade02342 /meta-agl-profile-core/recipes-test/blobsallad/blobsallad/0001-Makefile.patch
parent97e5e76efa44f55ee9aaf3998bb3df38b829706c (diff)
Introduce meta-agl-profile-core and meta-agl-profile-graphics
Rework towards agl profiles. This change is part of a series of changes to create the AGL profiles. This set will mainly introduce the 'core' profile. It is setup to be a drop-in change, thus some files were kept in (dummy) locations for now. However, they'll be taken care of in the next changes in this series. The main target of the meta-agl-profile-core layer is to host: - a minimal, bootable image with network and package management enabled -- agl-image-boot - a minimal image with network and packagemanagement and the AGL APIs -- agl-image-minimal The layer meta-agl-profile-graphical is used as superset of these and includes support for egl+wayland+weston. All recipes concerning graphics were moved there. This is not a full profile as we still have to migrate some parts of meta-agl-demo in a follow-up changeset. The roadmap as discussed during the F2F session in Karlsruhe is: - week 16 : core profile and profiles w/o graphics - week 17 : graphical profiles - week 18 : final conversion of the demo image v2: moved agl-login-manager from -graphics to -core (see Jose's comment) v3: moved back after discussion - follow-up in separate changeset Change-Id: Idacb0d1274baac1f63f8d1b850d4b1104ac33918 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-core/recipes-test/blobsallad/blobsallad/0001-Makefile.patch')
-rw-r--r--meta-agl-profile-core/recipes-test/blobsallad/blobsallad/0001-Makefile.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-test/blobsallad/blobsallad/0001-Makefile.patch b/meta-agl-profile-core/recipes-test/blobsallad/blobsallad/0001-Makefile.patch
new file mode 100644
index 000000000..0ae56cee1
--- /dev/null
+++ b/meta-agl-profile-core/recipes-test/blobsallad/blobsallad/0001-Makefile.patch
@@ -0,0 +1,53 @@
+--- a/Makefile.orig 2016-04-01 15:50:20.636358716 +0200
++++ b/Makefile 2016-04-01 15:51:58.916361191 +0200
+@@ -1,3 +1,9 @@
++INCDIR = $(SDKROOT)/usr/include
++LIBDIR = $(SDKROOT)/usr/lib
++
++EXTRA_CFLAGS=-I$(INCDIR)
++EXTRA_LDFLAGS=-Wl,-rpath-link=$(LIBDIR) -L$(LIBDIR)
++
+ OBJECTS = bs_main.o \
+ bs_vector.o \
+ bs_pointmass.o \
+@@ -15,21 +21,21 @@
+ bs_profiler.o \
+ bs_rubberband.o
+
+-CC = gcc
++#CC = gcc
+
+ DISTDIR = blobsallad-src
+
+-CFLAGS = `pkg-config --cflags cairo; sdl-config --cflags`
+-LIBS = `pkg-config --libs cairo; sdl-config --libs` -lm -lGL -lGLU
++EXTRA_CFLAGS += -I$(INCDIR)/cairo -I$(INCDIR)/SDL -D_GNU_SOURCE=1 -D_REENTRANT
++EXTRA_LDFLAGS += -lcairo -lSDL -lpthread -lm
+
+ all: $(OBJECTS)
+- $(CC) -g -o blobsallad $(OBJECTS) $(LIBS)
++ $(CC) -g -o blobsallad $(OBJECTS) $(EXTRA_LDFLAGS)
+
+ map:
+- gcc -o createmap create_testdata.c -Wall -g -lm
++ $(CC) -o createmap create_testdata.c -Wall -g -lm
+
+ octree:
+- gcc -o test_octree test_octree.c bs_octree.c bs_list.c bs_vector.c bs_vector_util.c bs_timer.c bs_array.c -Wall -O2 $(LIBS) $(CFLAGS)
++ $(CC) -o test_octree test_octree.c bs_octree.c bs_list.c bs_vector.c bs_vector_util.c bs_timer.c bs_array.c -Wall -O2 $(EXTRA_LDFLAGS) $(EXTRA_CFLAGS)
+
+ GFX_OBJECTS = gfx_main.o \
+ bs_gfx.o \
+@@ -41,10 +47,10 @@
+ bs_list.o
+
+ gfx: $(GFX_OBJECTS)
+- gcc -o gfx_main -Wall -g $(GFX_OBJECTS) $(LIBS)
++ $(CC) -o gfx_main -Wall -g $(GFX_OBJECTS) $(EXTRA_LDFLAGS)
+
+ .c.o:
+- $(CC) -g -Wall $(CFLAGS) $ -c $<
++ $(CC) -g -Wall $(EXTRA_CFLAGS) $ -c $<
+
+ clean:
+ rm -f *.o; rm -f blobsallad;