summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-09-02 16:24:39 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-09-03 16:02:41 +0000
commit72e884bc11ac69de9491620fa8b32cee928e05ba (patch)
treea0568d93737ae9ce274a59685c46cfdd266ae2f8 /meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb
parent6976dc76c4bfaed7ec519c8d0d8c9d39396c9469 (diff)
meta-agl-profile-core: add pyagl to agl-devel images
Changes: - Add recipe for pyagl, and add it as a dependency of packagegroup-agl-core-devel. - Add recipes for pyagl dependencies python3-asyncssh, python3-pytest-dependency, and python3-pytest-reverse. The intent is to get these into upstream meta-python so these local copies can be dropped when they're available from there. Bug-AGL: SPEC-3562 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I876ef2fffbe8724aadb23170e1ed196f05132f89 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25176 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb')
-rw-r--r--meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb b/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb
new file mode 100644
index 000000000..770fdac66
--- /dev/null
+++ b/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Python bindings and tests for Automotive Grade Linux services"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/pyagl"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/pyagl;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "f583233db298a709a813d8c0af97769ba30ae002"
+PV = "${AGL_BRANCH}+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+RDEPENDS_${PN} += " \
+ python3-asyncio \
+ python3-asyncssh \
+ python3-core \
+ python3-json \
+ python3-logging \
+ python3-math \
+ python3-parse \
+ python3-pprint \
+ python3-pytest \
+ python3-pytest-asyncio \
+ python3-pytest-dependency \
+ python3-pytest-reverse \
+ python3-typing \
+ python3-websockets \
+"