summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-08-19 13:51:53 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-08-20 12:05:57 +0000
commitda06a51ad4b3f7e411bb6efd73a80370757a9991 (patch)
treee5252c951aebf704aa4ce2f1f67ff98e90f200bb /meta-agl-profile-core
parent4cd27637de939f27d4aa581d842f746f6e69b90d (diff)
Enable J1939 support for qemu machines
Tweak the can-bus.cfg kernel configuration fragment to set CONFIG_CAN_J1939, and add an over-ride in the agl-service-can-low-level recipe to enable J1939 support on qemu platforms where we know we have a 5.4 kernel where it will work. Bug-AGL: SPEC-3538 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I16e77a70794dd79ac37139dd19b15a9e131cbf3e Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25139 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-core')
-rw-r--r--meta-agl-profile-core/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb b/meta-agl-profile-core/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb
index d06cfd26a..83f6c1e75 100644
--- a/meta-agl-profile-core/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb
+++ b/meta-agl-profile-core/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb
@@ -16,4 +16,8 @@ DEPENDS = "libafb-helpers libappcontroller"
inherit cmake aglwgt pkgconfig ptest
+# For now, just enable J1939 on the qemu platforms where we know the
+# linux-yocto kernel is new enough (>= 5.4) and has the support enabled.
+AGLWGT_CMAKE_CONFIGURE_ARGS_append_qemuall = " -DWITH_FEATURE_J1939=ON"
+
RDEPENDS_${PN} = "virtual/low-can-dev-mapping"