summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-01-22 20:16:24 -0500
committerScott Murray <scott.murray@konsulko.com>2020-01-22 20:16:24 -0500
commit3d1b86d90152cd03ac9df81e189886076c00f14c (patch)
tree9d2fd69b5444e7b82a44594158b6cba5ded8fc03 /meta-agl-profile-core
parenta5110d6031ecd5343114d74d2b463234342c12a0 (diff)
meta-agl-profile-core: update fontconfig bbappend
Update fontconfig bbappend to work with the newer fontconfig 2.13.1 in oe-core in zeus. Bug-AGL: SPEC-2932 Change-Id: I7dfbe73def6b461915cdfa0131e1a529e1d3a5fd Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-profile-core')
-rw-r--r--meta-agl-profile-core/recipes-test/fontconfig/fontconfig_%.bbappend9
1 files changed, 5 insertions, 4 deletions
diff --git a/meta-agl-profile-core/recipes-test/fontconfig/fontconfig_%.bbappend b/meta-agl-profile-core/recipes-test/fontconfig/fontconfig_%.bbappend
index c4bebdc1f..e8ce1ab78 100644
--- a/meta-agl-profile-core/recipes-test/fontconfig/fontconfig_%.bbappend
+++ b/meta-agl-profile-core/recipes-test/fontconfig/fontconfig_%.bbappend
@@ -1,16 +1,17 @@
-PACKAGES =+ "fontconfig-test"
-
do_install_append() {
install -m 755 -d ${D}/${datadir}/fontconfig-test
install -m 755 ${S}/test/run-test.sh ${D}/${datadir}/fontconfig-test/
- sed -i -e "s/FCLIST=\.\.\/fc\-list\/fc\-list/FCLIST=\/usr\/bin\/fc\-list/g" -e "s/FCCACHE=\.\.\/fc\-cache\/fc\-cache/FCCACHE=\/usr\/bin\/fc\-cache/g" ${D}/${datadir}/fontconfig-test/run-test.sh
+ sed -i -e "s#^FCLIST=\.\./fc-list/fc-list#FCLIST=/usr/bin/fc-list#g" -e "s#^FCCACHE=\.\./fc-cache/fc-cache#FCCACHE=/usr/bin/fc-cache#g" ${D}/${datadir}/fontconfig-test/run-test.sh
- for x in 4x6.pcf 8x16.pcf out.expected fonts.conf.in; do
+ install -m 644 ${B}/test/out.expected ${D}/${datadir}/fontconfig-test/
+ for x in 4x6.pcf 8x16.pcf fonts.conf.in; do
install -m 644 ${S}/test/$x ${D}/${datadir}/fontconfig-test/
done
}
+PACKAGES =+ "fontconfig-test"
+
DEBIAN_NOAUTONAME_fontconfig-test = "1"
FILES_fontconfig-test = "${datadir}/fontconfig-test/*"