summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-01-27 13:31:58 -0500
committerScott Murray <scott.murray@konsulko.com>2020-01-27 13:31:58 -0500
commitb7fdcead5a738b986d74ba8c00be88fe7a44af74 (patch)
tree9b2d6e2e109e12c2a33605c6de4aa8d61012dfc2 /meta-agl-profile-core
parent6aeb440d5e1e5155c866e91c3ec0f978122e8862 (diff)
meta-agl-profile-core: update most recipe
Update SRCREV in MOST driver recipe to pick up: e4dbbaf sound.c: Remove snd_pcm_lib_mmap_vmalloc As well, the following changes have been made to the bbappend: - the kernel version detection logic has been removed - the patch to support kernels older than 4.13 has been removed - the patch that was handling the snd_pcm_lib_mmap_vmalloc issue on kernels >= 4.19 has been reworked to add the required #ifdefs to support kernels < 4.19 for e.g. the rcar3 4.14-ltsi kernel. Bug-AGL: SPEC-2932 Change-Id: I388d186d04ccc017ff10b2024ae35ed22f7a8e36 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-profile-core')
-rw-r--r--meta-agl-profile-core/recipes-kernel/most/files/0001-most-aim-network-backport-Kernel-API.patch43
-rw-r--r--meta-agl-profile-core/recipes-kernel/most/files/0011-handle-snd_pcm_lib_mmap_vmalloc-removal.patch22
-rw-r--r--meta-agl-profile-core/recipes-kernel/most/most.bb2
-rw-r--r--meta-agl-profile-core/recipes-kernel/most/most.bbappend21
4 files changed, 20 insertions, 68 deletions
diff --git a/meta-agl-profile-core/recipes-kernel/most/files/0001-most-aim-network-backport-Kernel-API.patch b/meta-agl-profile-core/recipes-kernel/most/files/0001-most-aim-network-backport-Kernel-API.patch
deleted file mode 100644
index d43b132f2..000000000
--- a/meta-agl-profile-core/recipes-kernel/most/files/0001-most-aim-network-backport-Kernel-API.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 383ffadd33f484ab4aaeb14fa109b61143d27d58 Mon Sep 17 00:00:00 2001
-From: Christian Gromm <christian.gromm@microchip.com>
-Date: Thu, 7 Jun 2018 12:15:38 +0200
-Subject: [PATCH] most: aim-network: backport Kernel API
-
-This patch replaces the function calls skb_put_data with memcpy. It is
-needed to have the module compiled for kernels prior to 4.13.
-
-Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
----
- aim-network/networking.c | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/aim-network/networking.c b/aim-network/networking.c
-index 936f013..4c259c2 100644
---- a/aim-network/networking.c
-+++ b/aim-network/networking.c
-@@ -470,11 +470,11 @@ static int aim_rx_data(struct mbo *mbo)
- ether_addr_copy(skb_put(skb, ETH_ALEN), dev->dev_addr);
-
- /* src */
-- skb_put_data(skb, &zero, 4);
-- skb_put_data(skb, buf + 5, 2);
-+ memcpy(skb_put(skb, 4), &zero, 4);
-+ memcpy(skb_put(skb, 2), buf + 5, 2);
-
- /* eth type */
-- skb_put_data(skb, buf + 10, 2);
-+ memcpy(skb_put(skb, 2), buf + 10, 2);
-
- buf += MDP_HDR_LEN;
- len -= MDP_HDR_LEN;
-@@ -483,7 +483,7 @@ static int aim_rx_data(struct mbo *mbo)
- len -= MEP_HDR_LEN;
- }
-
-- skb_put_data(skb, buf, len);
-+ memcpy(skb_put(skb, len), buf, len);
- skb->protocol = eth_type_trans(skb, dev);
- skb_len = skb->len;
- if (netif_rx(skb) == NET_RX_SUCCESS) {
---
-2.11.0
diff --git a/meta-agl-profile-core/recipes-kernel/most/files/0011-handle-snd_pcm_lib_mmap_vmalloc-removal.patch b/meta-agl-profile-core/recipes-kernel/most/files/0011-handle-snd_pcm_lib_mmap_vmalloc-removal.patch
index 8f83dbab4..d4383c4f6 100644
--- a/meta-agl-profile-core/recipes-kernel/most/files/0011-handle-snd_pcm_lib_mmap_vmalloc-removal.patch
+++ b/meta-agl-profile-core/recipes-kernel/most/files/0011-handle-snd_pcm_lib_mmap_vmalloc-removal.patch
@@ -1,18 +1,30 @@
Handle snd_pcm_lib_mmap_vmalloc removal in 4.19
-Upstream-Status: Pending
+Add .mmap field back to pcm_ops for kernels older than 4.19.
+
+Upstream-Status: Inappropriate
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-diff --git a/driver/aim-sound/sound.c b/driver/aim-sound/sound.c
-index 6a290ff..4b3329b 100644
+diff --git a/aim-sound/sound.c b/aim-sound/sound.c
+index 4b3329b..c0a26be 100644
--- a/aim-sound/sound.c
+++ b/aim-sound/sound.c
-@@ -463,7 +463,6 @@ static const struct snd_pcm_ops pcm_ops = {
+@@ -17,6 +17,7 @@
+ #include <linux/printk.h>
+ #include <linux/kernel.h>
+ #include <linux/init.h>
++#include <linux/version.h>
+ #include <sound/core.h>
+ #include <sound/pcm.h>
+ #include <sound/pcm_params.h>
+@@ -463,6 +464,9 @@ static const struct snd_pcm_ops pcm_ops = {
.trigger = pcm_trigger,
.pointer = pcm_pointer,
.page = snd_pcm_lib_get_vmalloc_page,
-- .mmap = snd_pcm_lib_mmap_vmalloc,
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4,19,0)
++ .mmap = snd_pcm_lib_mmap_vmalloc,
++#endif
};
static int split_arg_list(char *buf, char **card_name, u16 *ch_num,
diff --git a/meta-agl-profile-core/recipes-kernel/most/most.bb b/meta-agl-profile-core/recipes-kernel/most/most.bb
index 4ec7e3c26..48959a6ee 100644
--- a/meta-agl-profile-core/recipes-kernel/most/most.bb
+++ b/meta-agl-profile-core/recipes-kernel/most/most.bb
@@ -9,6 +9,6 @@ PV = "0.1"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https;branch=${AGL_BRANCH}"
S = "${WORKDIR}/git/driver"
-SRCREV = "dcc04c5efe2058a5796f45b7a99f1c53082dd2ca"
+SRCREV = "e4dbbaf9e7652efaed0df3e0aab4464f5f228573"
KERNEL_MODULE_AUTOLOAD += "aim_cdev aim_sound aim_network aim_v4l2 hdm_i2c hdm_dim2 hdm_usb mostcore"
diff --git a/meta-agl-profile-core/recipes-kernel/most/most.bbappend b/meta-agl-profile-core/recipes-kernel/most/most.bbappend
index 17ad05585..b96625229 100644
--- a/meta-agl-profile-core/recipes-kernel/most/most.bbappend
+++ b/meta-agl-profile-core/recipes-kernel/most/most.bbappend
@@ -1,21 +1,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-def prep_version (d) :
- KV = d.getVar('KERNEL_VERSION', True)
- if not KV :
- return "4.12"
- else:
- return KV
-
-ORIG_KERN_VER = "${@prep_version(d)}"
-
-VANILLA_KERNEL_VERSION = "${@str(ORIG_KERN_VER.split("-")[0].split(".")[0]+ORIG_KERN_VER.split("-")[0].split(".")[1])}"
-
-APPLY = "${@str('no' if ${VANILLA_KERNEL_VERSION} > 412 else 'yes')}"
-APPLY_419 = "${@str('no' if ${VANILLA_KERNEL_VERSION} < 419 else 'yes')}"
-
SRC_URI_append = " \
- file://0001-most-aim-network-backport-Kernel-API.patch;apply=${APPLY} \
file://0002-src-most-add-auto-conf-feature.patch \
file://0003-core-remove-kernel-log-for-MBO-status.patch \
file://0004-most-video-set-device_caps.patch \
@@ -25,7 +10,5 @@ SRC_URI_append = " \
file://0008-dim2-read-clock-speed-from-the-device-tree.patch \
file://0009-dim2-use-device-for-coherent-memory-allocation.patch \
file://0010-backport-usb-setup-timer.patch \
- file://0011-handle-snd_pcm_lib_mmap_vmalloc-removal.patch;apply=${APPLY_419} \
- "
-# Make sure we can expose KERNEL_VERSION ...
-do_patch[depends] += "virtual/kernel:do_populate_sysroot"
+ file://0011-handle-snd_pcm_lib_mmap_vmalloc-removal.patch \
+"