summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-05-12 20:58:56 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-05-18 10:30:03 +0000
commitdad22a2b3c3cced169c4790e8fe5d8cf2cc62ee2 (patch)
tree72df19f3267cb0b45dfece356e4d4f5890e909b0 /meta-agl-profile-core
parenta954a264140745f6732695dcce9f84494504b758 (diff)
Rework test/debug image features and crosssdk image definitions
Changes include: - The agl-test-wgt/agl-devel-wgt image features and the scheme of appending to their FEATURE_PACKAGES definitions turned out to be problematic with respect to resulting in unexpected extra packages ending up in agl-image-{minimal,ivi}, etc., when building with agl-demo configured (which is typical usage). To avoid this, the FEATURE_PACKAGE definitions for the image features have been replaced with tweaks to define COMPLEMENTARY_GLOBS for the features to bring in the test/debug/coverage packages via that mechanism. - The above removes the need to define the extra test/devel packagegroups, and requires some minor tweaks to aglwgt.bbclass to use a -debug package for the debug widget instead of -dbg, to avoid collisions with the dbg-pkgs image feature. As well, the afb-test package has been added as to RDEPENDS of all test widget packages, since that seems sensible and avoids needing to explicitly adding it elsewhere. - Attempt to rework the various crosssdk image definitions to use a layered set of .inc files to remove duplication and ensure that additions to the SDK are declared once in the appropriate profile. It is likely that a clean sheet implementation would have some things coming from meta-agl-profile-graphical, so further rework may be required/desired to continue cleaning things up. Bug-AGL: SPEC-3300, SPEC-3375 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I942b61501beb41d037001b70a501f90b9a59c45d
Diffstat (limited to 'meta-agl-profile-core')
-rw-r--r--meta-agl-profile-core/conf/include/base-agl.inc4
-rw-r--r--[-rwxr-xr-x]meta-agl-profile-core/recipes-platform/images/agl-image-minimal-crosssdk.bb19
-rw-r--r--meta-agl-profile-core/recipes-platform/images/agl-image-minimal-crosssdk.inc18
-rw-r--r--meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-services.bb13
4 files changed, 19 insertions, 35 deletions
diff --git a/meta-agl-profile-core/conf/include/base-agl.inc b/meta-agl-profile-core/conf/include/base-agl.inc
index d568b067b..c5cf1a57f 100644
--- a/meta-agl-profile-core/conf/include/base-agl.inc
+++ b/meta-agl-profile-core/conf/include/base-agl.inc
@@ -2,10 +2,6 @@
# Comment this out to be able to select the kernel modules yourself.
IMAGE_INSTALL_append = " kernel-modules"
-# Base image feature package definitions for agl-test-wgt and agl-devel-wgt
-FEATURE_PACKAGES_agl-test-wgt = "packagegroup-agl-core-services-test"
-FEATURE_PACKAGES_agl-devel-wgt = "packagegroup-agl-core-services-devel"
-
# Likewise as we included all kernel modules by default in the filesystem,
# we do not need a separate tarball stored.
# Comment this out to receive the separate modules tarball again.
diff --git a/meta-agl-profile-core/recipes-platform/images/agl-image-minimal-crosssdk.bb b/meta-agl-profile-core/recipes-platform/images/agl-image-minimal-crosssdk.bb
index 27c1ee6d6..8c5aae1bf 100755..100644
--- a/meta-agl-profile-core/recipes-platform/images/agl-image-minimal-crosssdk.bb
+++ b/meta-agl-profile-core/recipes-platform/images/agl-image-minimal-crosssdk.bb
@@ -8,23 +8,7 @@ require agl-image-minimal.bb
LICENSE = "MIT"
-IMAGE_FEATURES_append = " dev-pkgs"
-IMAGE_INSTALL_append = " kernel-dev kernel-devsrc"
-
-# required dependencies for app and test builds
-# also in the minimal image (SPEC-1678)
-TOOLCHAIN_HOST_TASK += " \
- nativesdk-lua \
- "
-
-# required dependencies for app and test builds
-# also in the minimal image (SPEC-1678)
-TOOLCHAIN_TARGET_TASK += " \
- lua-dev \
- lua-staticdev \
- libafb-helpers-staticdev \
- libappcontroller-staticdev \
- "
+require agl-image-minimal-crosssdk.inc
inherit populate_sdk
@@ -32,4 +16,3 @@ inherit populate_sdk
# Both exec "createrepo" on the same directory, and so one of them
# can failed (randomly).
addtask do_populate_sdk after do_rootfs
-
diff --git a/meta-agl-profile-core/recipes-platform/images/agl-image-minimal-crosssdk.inc b/meta-agl-profile-core/recipes-platform/images/agl-image-minimal-crosssdk.inc
new file mode 100644
index 000000000..71812943c
--- /dev/null
+++ b/meta-agl-profile-core/recipes-platform/images/agl-image-minimal-crosssdk.inc
@@ -0,0 +1,18 @@
+IMAGE_FEATURES_append = " dev-pkgs"
+IMAGE_INSTALL_append = " kernel-dev kernel-devsrc"
+
+# Always include the test widgets
+IMAGE_FEATURES_append = " agl-test-wgt"
+
+# Required dependencies for app and test builds
+TOOLCHAIN_HOST_TASK += " \
+ nativesdk-lua \
+ "
+
+# Required dependencies for app and test builds
+TOOLCHAIN_TARGET_TASK += " \
+ lua-dev \
+ lua-staticdev \
+ libafb-helpers-staticdev \
+ libappcontroller-staticdev \
+ "
diff --git a/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-services.bb b/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-services.bb
index 9f7015992..2fd31d148 100644
--- a/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-services.bb
+++ b/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-services.bb
@@ -3,11 +3,8 @@ LICENSE = "MIT"
inherit packagegroup
-PROVIDES = "${PACKAGES}"
PACKAGES = "\
packagegroup-agl-core-services \
- packagegroup-agl-core-services-test \
- packagegroup-agl-core-services-devel \
"
RDEPENDS_${PN} += "\
@@ -15,13 +12,3 @@ RDEPENDS_${PN} += "\
agl-service-network \
agl-service-platform-info \
"
-
-RDEPENDS_${PN}-test = "\
- ${@' '.join([x + '-test' for x in str.split(d.getVar('RDEPENDS_${PN}'))])} \
- afb-test \
- "
-
-RDEPENDS_${PN}-devel = "\
- ${@' '.join([x + '-dbg' for x in str.split(d.getVar('RDEPENDS_${PN}'))])} \
- ${@' '.join([x + '-coverage' for x in str.split(d.getVar('RDEPENDS_${PN}'))])} \
- "