summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2020-02-25 08:45:09 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-02-27 22:19:00 +0000
commitf04c66c715d75aa2bfac6603dc1f973a48cca016 (patch)
tree329a19bc58f9b3eb7c4f525ba2322e65b2a8f0fa /meta-agl-profile-core
parent591eb0bfdf58a021cc324b7f0299f97a454df997 (diff)
bluez5: change obexd --root path to avoid SMACK issues
On startup obexd attempts to read from %HOMEDIR%/.cache/obexd or create the respective directory. Which is really not needed but causes failure to start with SMACK failures, and so workaround this by setting the parameter --root=/var/volatile/tmp Bug-AGL: SPEC-3206 Change-Id: I8b39a91d8d095d94b903a6607f6960f38ed08b5d Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
Diffstat (limited to 'meta-agl-profile-core')
-rw-r--r--meta-agl-profile-core/recipes-connectivity/bluez5/bluez5/obex.service10
-rw-r--r--meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend3
2 files changed, 13 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5/obex.service b/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5/obex.service
new file mode 100644
index 000000000..87ffff6ae
--- /dev/null
+++ b/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5/obex.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Bluetooth OBEX service
+
+[Service]
+Type=dbus
+BusName=org.bluez.obex
+ExecStart=/usr/libexec/bluetooth/obexd --root=/var/volatile/tmp
+
+[Install]
+Alias=dbus-org.bluez.obex.service
diff --git a/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend b/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend
index 36fb31517..9ee1db24e 100644
--- a/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend
+++ b/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend
@@ -2,6 +2,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
SRC_URI_append = " \
file://bluetooth.conf \
file://tmpdir.conf \
+ file://obex.service \
file://0001-obex-report-notification-status-on-incoming-message.patch \
"
@@ -12,6 +13,8 @@ do_install_append() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
mkdir -p ${D}${systemd_user_unitdir}/obex.service.d
+
+ install -m 0644 ${WORKDIR}/obex.service ${D}${systemd_user_unitdir}
install -m 0644 ${WORKDIR}/tmpdir.conf ${D}${systemd_user_unitdir}/obex.service.d/tmpdir.conf
mkdir -p ${D}/etc/systemd/user
ln -sf ${systemd_user_unitdir}/obex.service ${D}/etc/systemd/user/dbus-org.bluez.obex.service