summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-demo/recipes-multimedia/audiomanager
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-16 22:14:52 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-20 17:07:06 +0200
commitbb0882c5dad030f676e424265ebcd869bb3ff899 (patch)
treed95bb2d7ad6b5ac47427f73babe015b0ade02342 /meta-agl-profile-demo/recipes-multimedia/audiomanager
parent97e5e76efa44f55ee9aaf3998bb3df38b829706c (diff)
Introduce meta-agl-profile-core and meta-agl-profile-graphics
Rework towards agl profiles. This change is part of a series of changes to create the AGL profiles. This set will mainly introduce the 'core' profile. It is setup to be a drop-in change, thus some files were kept in (dummy) locations for now. However, they'll be taken care of in the next changes in this series. The main target of the meta-agl-profile-core layer is to host: - a minimal, bootable image with network and package management enabled -- agl-image-boot - a minimal image with network and packagemanagement and the AGL APIs -- agl-image-minimal The layer meta-agl-profile-graphical is used as superset of these and includes support for egl+wayland+weston. All recipes concerning graphics were moved there. This is not a full profile as we still have to migrate some parts of meta-agl-demo in a follow-up changeset. The roadmap as discussed during the F2F session in Karlsruhe is: - week 16 : core profile and profiles w/o graphics - week 17 : graphical profiles - week 18 : final conversion of the demo image v2: moved agl-login-manager from -graphics to -core (see Jose's comment) v3: moved back after discussion - follow-up in separate changeset Change-Id: Idacb0d1274baac1f63f8d1b850d4b1104ac33918 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-demo/recipes-multimedia/audiomanager')
-rw-r--r--meta-agl-profile-demo/recipes-multimedia/audiomanager/audiomanager/0001-Fix-duplicated-command-line-arg-t.patch25
-rw-r--r--meta-agl-profile-demo/recipes-multimedia/audiomanager/audiomanager/audiomanager.service17
-rw-r--r--meta-agl-profile-demo/recipes-multimedia/audiomanager/audiomanager_7.4.bb56
3 files changed, 98 insertions, 0 deletions
diff --git a/meta-agl-profile-demo/recipes-multimedia/audiomanager/audiomanager/0001-Fix-duplicated-command-line-arg-t.patch b/meta-agl-profile-demo/recipes-multimedia/audiomanager/audiomanager/0001-Fix-duplicated-command-line-arg-t.patch
new file mode 100644
index 000000000..fcdf9c540
--- /dev/null
+++ b/meta-agl-profile-demo/recipes-multimedia/audiomanager/audiomanager/0001-Fix-duplicated-command-line-arg-t.patch
@@ -0,0 +1,25 @@
+From c4b6030f575e38dfc9cca7dfd029d207f3af6a13 Mon Sep 17 00:00:00 2001
+From: "Andre Moreira Magalhaes (andrunko)" <andre.magalhaes@collabora.co.uk>
+Date: Thu, 5 May 2016 00:01:19 -0300
+Subject: [PATCH] Fix duplicated command line arg -t.
+
+---
+ AudioManagerDaemon/src/main.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/AudioManagerDaemon/src/main.cpp b/AudioManagerDaemon/src/main.cpp
+index 795795d..67c0977 100755
+--- a/AudioManagerDaemon/src/main.cpp
++++ b/AudioManagerDaemon/src/main.cpp
+@@ -87,7 +87,7 @@ TCLAP::ValueArg<std::string> commandPluginDir("l","CommandPluginDir","path for l
+ TCLAP::ValueArg<std::string> databasePath ("p","databasePath","path for sqlite database (default is in memory)",false,":memory:","string");
+ TCLAP::ValueArg<unsigned int> telnetPort ("t","telnetport","The port that is used for telnet",false,DEFAULT_TELNETPORT,"int");
+ TCLAP::ValueArg<unsigned int> maxConnections ("m","maxConnections","Maximal number of connections for telnet",false,MAX_TELNETCONNECTIONS,"int");
+-TCLAP::SwitchArg dbusWrapperTypeBool ("t","dbusType","DbusType to be used by CAmDbusWrapper: if option is selected, DBUS_SYSTEM is used otherwise DBUS_SESSION",false);
++TCLAP::SwitchArg dbusWrapperTypeBool ("T","dbusType","DbusType to be used by CAmDbusWrapper: if option is selected, DBUS_SYSTEM is used otherwise DBUS_SESSION",false);
+ TCLAP::SwitchArg enableNoDLTDebug ("V","logDlt","print DLT logs to stdout",false);
+ TCLAP::SwitchArg currentSettings("i","currentSettings","print current settings and exit",false);
+ TCLAP::SwitchArg daemonizeAM("d","daemonize","daemonize Audiomanager. Better use systemd...",false);
+--
+2.5.0
+
diff --git a/meta-agl-profile-demo/recipes-multimedia/audiomanager/audiomanager/audiomanager.service b/meta-agl-profile-demo/recipes-multimedia/audiomanager/audiomanager/audiomanager.service
new file mode 100644
index 000000000..2210a377b
--- /dev/null
+++ b/meta-agl-profile-demo/recipes-multimedia/audiomanager/audiomanager/audiomanager.service
@@ -0,0 +1,17 @@
+# AudioManager systemd service file
+
+[Unit]
+Description=GENIVI AudioManager
+Requires=dbus.service
+After=dbus.service
+Before=pulseaudio.service
+
+[Service]
+Type=notify
+ExecStart=/usr/bin/AudioManager -T
+Restart=always
+TimeoutSec=2
+WatchdogSec=2
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-agl-profile-demo/recipes-multimedia/audiomanager/audiomanager_7.4.bb b/meta-agl-profile-demo/recipes-multimedia/audiomanager/audiomanager_7.4.bb
new file mode 100644
index 000000000..15eb36252
--- /dev/null
+++ b/meta-agl-profile-demo/recipes-multimedia/audiomanager/audiomanager_7.4.bb
@@ -0,0 +1,56 @@
+DESCRIPTION = "GENIVI Audio Manager"
+HOMEPAGE = "http://projects.genivi.org/audio-manager/home"
+LICENSE = "MPLv2"
+SECTION = "multimedia"
+DEPENDS = "dbus dlt-daemon systemd"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=f164349b56ed530a6642e9b9f244eec5"
+
+SRC_URI = " \
+ git://github.com/GENIVI/AudioManager.git;protocol=https;branch=master \
+ file://audiomanager.service \
+"
+RDEPENDS_${PN} = "audiomanager-plugins module-router"
+SRCREV = "daf851ee7a41d1b0572c0c95e15f61e427ce97f1"
+
+S = "${WORKDIR}/git"
+inherit cmake systemd
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "audiomanager.service"
+SYSTEMD_AUTO_ENABLE = "enable"
+
+EXTRA_OECMAKE = " \
+ -DWITH_TESTS=OFF \
+ -DWITH_DOCUMENTATION=OFF \
+ -DWITH_DLT=ON \
+ -DWITH_TELNET=OFF \
+ -DWITH_SYSTEMD_WATCHDOG=ON \
+ -DGLIB_DBUS_TYPES_TOLERANT=ON \
+ -DWITH_CAPI_WRAPPER=OFF \
+ -DWITH_DBUS_WRAPPER=ON \
+ -DWITH_SHARED_UTILITIES=ON \
+ -DWITH_SHARED_CORE=ON \
+"
+
+FILES_${PN} = " \
+ ${bindir}/AudioManager \
+ ${libdir}/libAudioManagerCore.so.7 \
+ ${libdir}/libAudioManagerCore.so.7.4 \
+ ${libdir}/libAudioManagerCore.so.7.4.12 \
+ ${libdir}/libAudioManagerUtilities.so.7 \
+ ${libdir}/libAudioManagerUtilities.so.7.4 \
+ ${libdir}/libAudioManagerUtilities.so.7.4.12 \
+ ${systemd_unitdir}/audiomanager.service \
+"
+
+FILES_${PN}-dev = " \
+ ${includedir}/audiomanager/* \
+ ${libdir}/cmake/* \
+ ${libdir}/pkgconfig/* \
+ ${libdir}/libAudioManagerCore.so \
+ ${libdir}/libAudioManagerUtilities.so \
+"
+
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/audiomanager.service ${D}${systemd_unitdir}/system/
+}