summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-demo/recipes-qt/qml-execscript-plugin/qml-execscript-plugin_1.0.bb
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-24 15:13:18 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-28 00:28:55 +0200
commit4ac99c3a1447119363935fb986f5d9c05f032362 (patch)
treed4fdce1f65606af5111e6e4d5d21b198de9f2bf2 /meta-agl-profile-demo/recipes-qt/qml-execscript-plugin/qml-execscript-plugin_1.0.bb
parentbb0882c5dad030f676e424265ebcd869bb3ff899 (diff)
2nd part of the layer/profile rework [1/2]
Main goal of this is to move the agl-service-* bindings into the core and to unify common recipes like wayland/weston into meta-agl-profile-graphical. As a placeholder for recipes is meta-agl-profile-demo which are being reshuffled. TLDR: agl-service move to meta-agl-profile-core. wayland/weston moves to meta-agl-profile-graphical. This patchset needs the 2nd patchset of the series to build (meta-agl-demo). Bug-AGL: SPEC-145 , SPEC-876 , SPEC-877 v2: rebase including udiscs patches from meta-agl-demo Change-Id: I5e33f72d01707fa8b826d382bccaca3addcbbc47 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-demo/recipes-qt/qml-execscript-plugin/qml-execscript-plugin_1.0.bb')
-rw-r--r--meta-agl-profile-demo/recipes-qt/qml-execscript-plugin/qml-execscript-plugin_1.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-agl-profile-demo/recipes-qt/qml-execscript-plugin/qml-execscript-plugin_1.0.bb b/meta-agl-profile-demo/recipes-qt/qml-execscript-plugin/qml-execscript-plugin_1.0.bb
new file mode 100644
index 000000000..dbeda2d11
--- /dev/null
+++ b/meta-agl-profile-demo/recipes-qt/qml-execscript-plugin/qml-execscript-plugin_1.0.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Execute Script QML plugin"
+DESCRIPTION = "This provides a simple QML plugin able to execute script file."
+
+LICENSE = "CLOSED"
+
+DEPENDS = "qtbase-native qtdeclarative"
+
+SRC_URI = "git://github.com/ntanibata/qml-execscript-plugin.git;protocol=git;"
+SRCREV = "1f05c44cccd8aef485d8df8206c8df4e5ad6f310"
+S = "${WORKDIR}/git"
+
+inherit qmake5
+
+EXTRA_OECONF = "--with-moc-dir=${STAGING_BINDIR_NATIVE}/qt5"
+QML_LIBDIR = "${libdir}/qt5/qml"
+
+do_install() {
+ install -d ${D}${libdir}/qt5/qml/execScript/
+ install -m 0755 execScript/*.so ${D}${libdir}/qt5/qml/execScript/
+ install -m 0644 ../git/execScript/qmldir ${D}${libdir}/qt5/qml/execScript/
+}
+
+FILES_${PN} += "${QML_LIBDIR}/execScript/libexecscriptplugin.so"
+FILES_${PN} += "${QML_LIBDIR}/execScript/qmldir"
+FILES_${PN}-dbg += "${QML_LIBDIR}/execScript/.debug"