summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical-html5/recipes-apis/agl-service-windowmanager
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-06-25 19:47:24 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-06-26 14:37:56 +0000
commit4ce8411bb9c47a59d67ffe431f43cc4bc408dce1 (patch)
tree327687c68d5e57f2aaed9d667872db13b965d872 /meta-agl-profile-graphical-html5/recipes-apis/agl-service-windowmanager
parent6ba0b4d2b38b88fef8bb847fe8631995d72910b6 (diff)
Move meta-agl-profile-graphical-html5 and meta-pipewire into the main layer
Reasoning: - the profile-graphical-html5 belongs in the main layer - meta-pipewire is enabled by default For reference - the original location is: https://gerrit.automotivelinux.org/gerrit/gitweb?p=AGL%2Fmeta-agl-devel.git;a=commit;h=8479cd0c37e5e5e207a16f21c864610103e4f20f Bug-AGL: SPEC-3453 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> Change-Id: Ib475331bb6f84437020728fbb3f17b4acaab0106 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/24875 Reviewed-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-profile-graphical-html5/recipes-apis/agl-service-windowmanager')
-rw-r--r--meta-agl-profile-graphical-html5/recipes-apis/agl-service-windowmanager/agl-service-windowmanager_git.bbappend9
-rw-r--r--meta-agl-profile-graphical-html5/recipes-apis/agl-service-windowmanager/files/areas.horizontal.json94
2 files changed, 103 insertions, 0 deletions
diff --git a/meta-agl-profile-graphical-html5/recipes-apis/agl-service-windowmanager/agl-service-windowmanager_git.bbappend b/meta-agl-profile-graphical-html5/recipes-apis/agl-service-windowmanager/agl-service-windowmanager_git.bbappend
new file mode 100644
index 000000000..06f89f691
--- /dev/null
+++ b/meta-agl-profile-graphical-html5/recipes-apis/agl-service-windowmanager/agl-service-windowmanager_git.bbappend
@@ -0,0 +1,9 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI += " \
+ file://areas.horizontal.json \
+"
+
+do_compile_prepend() {
+ cp ${WORKDIR}/areas.horizontal.json ${S}/conf/areas.json
+}
diff --git a/meta-agl-profile-graphical-html5/recipes-apis/agl-service-windowmanager/files/areas.horizontal.json b/meta-agl-profile-graphical-html5/recipes-apis/agl-service-windowmanager/files/areas.horizontal.json
new file mode 100644
index 000000000..4b6f0c392
--- /dev/null
+++ b/meta-agl-profile-graphical-html5/recipes-apis/agl-service-windowmanager/files/areas.horizontal.json
@@ -0,0 +1,94 @@
+{
+ "areas": [
+ {
+ "name": "fullscreen",
+ "rect": {
+ "x": 0,
+ "y": 0,
+ "w": 1920,
+ "h": 1080
+ }
+ },
+ {
+ "name": "normal.full",
+ "rect": {
+ "x": 218,
+ "y": 0,
+ "w": 1702,
+ "h": 1080
+ }
+ },
+ {
+ "name": "split.main",
+ "rect": {
+ "x": 218,
+ "y": 0,
+ "w": 744,
+ "h": 1080
+ }
+ },
+ {
+ "name": "split.sub",
+ "rect": {
+ "x": 962,
+ "y": 0,
+ "w": 744,
+ "h": 1080
+ }
+ },
+ {
+ "name": "software_keyboard",
+ "rect": {
+ "x": 962,
+ "y": 0,
+ "w": 744,
+ "h": 1080
+ }
+ },
+ {
+ "name": "restriction.normal",
+ "rect": {
+ "x": 218,
+ "y": 0,
+ "w": 1488,
+ "h": 1080
+ }
+ },
+ {
+ "name": "restriction.split.main",
+ "rect": {
+ "x": 218,
+ "y": 0,
+ "w": 744,
+ "h": 1080
+ }
+ },
+ {
+ "name": "restriction.split.sub",
+ "rect": {
+ "x": 962,
+ "y": 0,
+ "w": 744,
+ "h": 1080
+ }
+ },
+ {
+ "name": "on_screen",
+ "rect": {
+ "x": 218,
+ "y": 0,
+ "w": 1488,
+ "h": 1080
+ }
+ },
+ {
+ "name": "remote.fullscreen",
+ "rect": {
+ "x": 0,
+ "y": 0,
+ "w": 720,
+ "h": 640
+ }
+ }
+ ]
+}