summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-06-24 17:47:43 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-06-24 17:48:35 +0200
commit54c2fda805fd7fda591008693cd6843413cee9f8 (patch)
tree16ab8f0ac5ba32e6741849eede7610bcfe844925 /meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
parent8e93c36104e8cd3f319170d70b60c705fd7fa402 (diff)
parent95b8edd4aab48f4cb66f3119e91e59ab74f907e9 (diff)
Merge the agl-compositor sandbox into master
The changes prepared by Marius for agl-compositor have been reviewed in the sandbox/mvlad/agl-compositor. This is the merge to master. Notes: - weston+ivi-shell+windowmanager are replaced using agl-compositor - applications have been adapted accordingly - CI will likely fail as we need to merge all related patches Updating 8e93c361..95b8edd4 Fast-forward meta-agl-bsp/conf/include/agl_rcar.inc | 11 ++++++++++ meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend | 4 ++-- meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb | 6 +++++- meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend | 7 +++--- .../recipes-platform/packagegroups/packagegroup-agl-graphical-weston.bb | 3 +-- meta-app-framework/recipes-core/af-main/af-main_git.inc | 2 +- templates/base/99_local.conf.inc | 14 ++++++++++++ templates/feature/agl-compositor/50_local.conf.inc | 48 ----------------------------------------- templates/feature/agl-compositor/README_feature_agl-compositor.md | 13 ----------- 9 files changed, 38 insertions(+), 70 deletions(-) Bug-AGL: SPEC-3444 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> Change-Id: Iea2b7367fdf1c9874b4b76a016b9d1a181b0e791
Diffstat (limited to 'meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend')
-rw-r--r--meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend b/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
index 6472c7eff..85ebc29d6 100644
--- a/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
+++ b/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
@@ -24,12 +24,12 @@ SRC_URI_append = "\
file://0010-Added-manifest-file-according-to-smack-3-domain-mode.patch \
"
-DEFAULT_WM_SHELL = "${@bb.utils.contains('DISTRO_FEATURES', 'agl-compositor', 'xdg-shell', 'ivi-shell', d)}"
+AGL_DEFAULT_WM_SHELL ?= "xdg-shell"
AFM_CONF_DIR = "${D}${sysconfdir}/afm/unit.env.d"
QT_SHELL_FILE = "${AFM_CONF_DIR}/qt-shell"
do_install_append_class-target() {
mkdir -p ${AFM_CONF_DIR}
- echo "QT_WAYLAND_SHELL_INTEGRATION=${DEFAULT_WM_SHELL}" > ${QT_SHELL_FILE}
+ echo "QT_WAYLAND_SHELL_INTEGRATION=${AGL_DEFAULT_WM_SHELL}" > ${QT_SHELL_FILE}
echo "QT_WAYLAND_RESIZE_AFTER_SWAP=1" >> ${QT_SHELL_FILE}
}