summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-05-15 14:46:21 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-05-31 18:16:00 +0200
commitb43165328658087277b667152fdbc04fe07cba08 (patch)
treed1540adb65af28e41e9ebdfdbfe8b08470cb6887 /meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
parentc40ee88f6aa0b379787a9ea3c853a806892e0dd1 (diff)
3rd part of the layer/profile rework [1/2]
This is the last larger commit in this series and deals with the graphical part. We introduce the graphical profiles: - meta-agl-profile-graphical -- meta-agl-profile-graphical-html5 -- meta-agl-profile-graphical-qt5 Notable changes: - weston-ini-conf moved to the meta-agl-bsp layer. Most BSPs have bbappends, so we need to have the recipes present (but unused) even in the console images. - new image: agl-image-boot = terminal-only + network + package-manaager. Ready for using package-feeds - new image/sdk: agl-image-minimal-crosssdk - agl-service-mediaplayer has a dependency on weston, thus it cannot be in the 'core'. Moved it to profile-graphical. - The wayland-ivi-extension moved to the agl-demo-platform. - The app-framework layer included and pulled 'web-runtime' as dependency. This broke console-only images. This has been moved to be in meta-agl-demo only for now. - added and massaged the agl-features. - found and added a useful script 'oe-depends-dot' that helps to work with the dot files (produced with bitbake -g) Todo: - we'll need another pass through the packagegroups. The dependencies for the layers/profiles are now sorted-out but we might have to add/shuffle a few packages. For further details, see meta-agl/docs/profiles.md. v2: fix meta-agl/meta-security/conf/layer.conf - the immediate expansion previously used in there caused some recipes not being added to BBFILES. v3: fix packagegroup renaming (packagegroup-agl-devel -> packagegroup-agl-core-devel) v4: fix missing packagegroup inclusion (tnx Jose, Scott, Stephane) v5: fix missing packagegroup inclusion v6: explicitely put profile-graphical-qt5 on-top of profile-graphical v7: re-add 'procps' when agl-devel feature is on Bug-AGL: SPEC-145 Change-Id: I24cdcd1118932758d0c55d333338238f2a770877 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend')
-rw-r--r--meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend b/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
new file mode 100644
index 000000000..9807840ca
--- /dev/null
+++ b/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
@@ -0,0 +1,36 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+# QT_MODULE_BRANCH = "5.4"
+
+# TODO:
+# These patches for IVI-SHELL are tempolary disabled because of issues. And new
+# patches are proposed.
+#
+# file://0020-Add-IVI-Shell-protocol-file-version-patch-v6.patch \
+# file://0021-Implement-initial-IVI-Shell-support.patch \
+# file://0001-protocol-update-3rd-party-ivi-application-protocol.patch \
+# file://0002-qwaylandwindow-add-support-for-IVI-Surface-ID-proper.patch \
+#
+# The xdg-shell merged into upstream, so we don't need these patch anymore.
+# But xdg-shell doesn't work well in current AGL Distro because of
+# mismatch of protocol versions between server(weston) and client(Qt Apps).
+#
+# file://0016-xdg-shell-Add-xdg-shell-protocol-file-version-1.4.0.patch \
+# file://0017-xdg-shell-Add-minimize-feature-to-QWindow-using-wayl.patch \
+# file://0019-xdg-shell-upgrade-to-support-current-version-weston-.patch \
+#
+
+SRC_URI_append = "\
+ file://0010-Added-manifest-file-according-to-smack-3-domain-mode.patch \
+ "
+SRC_URI_append_checkforkrogoth = "\
+ file://disable_xcomposite_egl_qt_wayland_client_buffer_integration.patch \
+ file://0001-Implement-initial-IVI-shell-support-with-shell-integ.patch \
+ file://0002-Fix-multiple-QWindow.patch \
+ "
+
+
+DEPENDS_append_koelsch = " libegl gles-user-module"
+DEPENDS_append_porter = " ${@base_conditional('PREFERRED_PROVIDER_virtual/egl', 'mesa', 'mesa', 'libegl gles-user-module', d)}"
+
+SRC_URI_append = " file://0099_qtwayland_no_evdev.patch "