summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical/classes
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-01-27 12:36:33 -0500
committerScott Murray <scott.murray@konsulko.com>2020-01-27 12:56:27 -0500
commit4bc95c3f87907f918eec3b83c475054a5bdef376 (patch)
tree34cc11d0785fd83e68aee6bc4323b37268fcc89d /meta-agl-profile-graphical/classes
parenta1ff5158b4e59e02533454b5582edf084387ba3d (diff)
meta-agl-profile-graphical: update weston and weston-init
Update weston and weston-init bbappends to handle weston 6.0.0 to 7.0.0 upgrade and other upstream changes: - weston 6.0.0 bbappend renamed for weston 7.0.0. - Wildcard weston_%.bbappend removed, as none of its changes are required with the latest upstream recipe. - Update weston patches for 7.0.0. Notable changes are that the patch to allow launching weston as a non-root user has been reworked for the switch to meson for weston builds, and the compositor backend patch for Waltham has been disabled until someone more familiar with the code can update it. - weston-init changes and udev rules updated to work with upstream support for running weston as non-root. The major rework is to simplify things such that all AGL configuration is done as an over-ride to the new upstream weston@.service file. The ability to specify which TTY to run weston on has been removed in favor of upstream's hard-coded tty7 as part of this change, to cut down on the amount of extra configuration required. Bug-AGL: SPEC-2932 Change-Id: I6f8b213bacb2de7526aa1a3c01b1482be78becef Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-profile-graphical/classes')
-rw-r--r--meta-agl-profile-graphical/classes/agl-graphical.bbclass5
1 files changed, 2 insertions, 3 deletions
diff --git a/meta-agl-profile-graphical/classes/agl-graphical.bbclass b/meta-agl-profile-graphical/classes/agl-graphical.bbclass
index e99a441b7..65106db18 100644
--- a/meta-agl-profile-graphical/classes/agl-graphical.bbclass
+++ b/meta-agl-profile-graphical/classes/agl-graphical.bbclass
@@ -1,7 +1,6 @@
-WESTONTTY ??= "1"
WESTONUSER ??= "display"
WESTONGROUP ??= "display"
-WESTONARGS ?= "--idle-time=0 --tty=${WESTONTTY}"
-WESTONLAUNCHARGS ??= "--tty /dev/tty${WESTONTTY} --user ${WESTONUSER}"
+WESTONARGS ?= "--idle-time=0 --tty=7"
+WESTONLAUNCHARGS ??= "--tty /dev/tty7 --user ${WESTONUSER}"
DISPLAY_XDG_RUNTIME_DIR ??= "/run/platform/${WESTONUSER}"