summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical/recipes-apis/agl-service-radio
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2019-06-09 19:58:25 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2019-06-23 00:38:53 +0200
commitc0288d2da00b12251199f3b693add13fb18ff354 (patch)
tree3d43f06c5a8b7756dc6872e289758f76623fa913 /meta-agl-profile-graphical/recipes-apis/agl-service-radio
parent075d872edc9fbec1463e0ef164a2db88f5f5427b (diff)
Move the agl-service-radio to the graphical profile
The agl-service-radio relies on gstreamer. Unfortunately the gstreamer recipe is currently setup to also pull-in wayland (due to a compile-flag if wayland is in DISTRO_FEATURES). To keep the distro aligned, we don't want to change the DISTRO_FEATURES between the profiles, thus we move the agl-service radio to the graphical profile where we include weston anyway by default. For now this means there is no radio service (or mediaplayer service) w/o wayland installed as well. In case we get this requirement, we'll have to work on the gstreamer recipe and its split. v2: fix bbapend in meta-agl-bsp/meta-rcar-gen3 v3: put packagegroup-agl-graphical-multimedia.bbappend in graphical profile (not the best place IMHO) This fixes the non-graphical build. Bug-AGL: SPEC-2500 Change-Id: I5ebec7d7713510f3fcd50ae425d7f8cbb6328016 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-graphical/recipes-apis/agl-service-radio')
-rw-r--r--meta-agl-profile-graphical/recipes-apis/agl-service-radio/agl-service-radio_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-agl-profile-graphical/recipes-apis/agl-service-radio/agl-service-radio_git.bb b/meta-agl-profile-graphical/recipes-apis/agl-service-radio/agl-service-radio_git.bb
new file mode 100644
index 000000000..b8f48ed7e
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-apis/agl-service-radio/agl-service-radio_git.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Radio Service Binding"
+DESCRIPTION = "AGL Radio Service Binding"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-radio"
+SECTION = "apps"
+LICENSE = "Apache-2.0 & GPLv2+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
+ file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-radio;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS = "rtl-sdr glib-2.0 gstreamer1.0 libusb-compat"
+
+inherit cmake aglwgt pkgconfig