summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical/recipes-graphics/wayland/waltham-transmitter_git.bb
diff options
context:
space:
mode:
authorNaoko Tanibata <tnaoko@jp.adit-jv.com>2018-04-11 16:15:33 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-11-13 14:30:29 +0000
commit4a17dd7bc0114a8a6baffa27c5e5b2659093fa75 (patch)
tree06ee8f3bd95ca23bc1c7a40c04d0c063563f962e /meta-agl-profile-graphical/recipes-graphics/wayland/waltham-transmitter_git.bb
parent611497f75ee8d128b8911b50d1be4e3c45f805d9 (diff)
meta-agl: introduce transmitter plugin to weston
The waltham-transmitter is the plugin of weston to enable client apps to share its surface between multiple domains. v2 (jsmoeller): rebased to new layer structure v3 (jsmoeller): squashed with previous commit v4 (jsmoeller): merge with https://gerrit.automotivelinux.org/gerrit/#/c/16187 to keep addition together in one patch v5 (jsmoeller): remove unneeded file v6 (jsmoeller): merge with https://gerrit.automotivelinux.org/gerrit/#/c/17223/ to keep addition together in one patch (cherry picked from commit d3ebc4bf2eb0331226ef4eac79aaacd520ee5a60) v7 (jsmoeller): After discussions during the integration session: - fix hardcoded lib64 in source code - reduce package to just transmitter (render is part of the transmitter) - include waltham-transmitter in packagegroup (might not be final place) v8 (tnaoko) : add missing dependency plugins. Change-Id: I7e607ed183f147fc0078bef54639207cfca80c6e Signed-off-by: Wataru Mizuno <wmizuno@jp.adit-jv.com> Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> Signed-off-by: Naoko Tanibata <tnaoko@jp.adit-jv.com>
Diffstat (limited to 'meta-agl-profile-graphical/recipes-graphics/wayland/waltham-transmitter_git.bb')
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/waltham-transmitter_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/waltham-transmitter_git.bb b/meta-agl-profile-graphical/recipes-graphics/wayland/waltham-transmitter_git.bb
new file mode 100644
index 000000000..4211dd2af
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/waltham-transmitter_git.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Waltham is a network IPC library designed to resemble Wayland both protocol and protocol-API wise"
+HOMEPAGE = "https://github.com/waltham/waltham"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://waltham-transmitter/COPYING;md5=f21c9af4de068fb53b83f0b37d262ec3"
+
+DEPENDS += "libdrm virtual/kernel wayland waltham weston gstreamer1.0 gstreamer gstreamer1.0-plugins-base gstreamer1.0-plugins-good"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/weston-ivi-plugins.git;protocol=https"
+SRCREV = "a1974a6a8cf8ed073b08bc65b01a6a6e99251723"
+
+S = "${WORKDIR}/git/"
+
+WALTHAM_PIPELINE ?= "waltham-transmitter/waltham-renderer/pipeline_example_general.cfg"
+WALTHAM_RECIEVER_IP ?= "192.168.1.2"
+WALTHAM_RECEIVER_PORT ?= "3440"
+
+inherit pkgconfig cmake
+
+do_install_append () {
+ install -d ${D}/etc/xdg/weston/
+ install ${S}/${WALTHAM_PIPELINE} ${D}/etc/xdg/weston/pipeline.cfg
+
+ sed -i -e "s/YOUR_RECIEVER_IP/${WALTHAM_RECIEVER_IP}/g" ${D}/etc/xdg/weston/pipeline.cfg
+ sed -i -e "s/YOUR_RECIEVER_PORT/${WALTHAM_RECEIVER_PORT}/g" ${D}/etc/xdg/weston/pipeline.cfg
+
+}
+
+FILES_${PN} += "/etc/xdg/weston/*.cfg"
+FILES_${PN} += "${libdir}/*"