summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical/recipes-graphics/wayland/waltham/0001-waltham-Fix-compile-build-error.patch
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2020-10-19 16:53:57 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-11-11 14:52:24 +0000
commite1aff45e1bd52213476a5dc59d7aa9abaa6db116 (patch)
treebb505cd43120d2fc892a3e68cd97b0e94048d52a /meta-agl-profile-graphical/recipes-graphics/wayland/waltham/0001-waltham-Fix-compile-build-error.patch
parent0d89af5ac5d55ca3250688a2ecfcd0f63e02d529 (diff)
waltham_%.bbappend: Added bbappend recipe for waltham
Waltham no longer compiles and it is required for waltham-transmitter-plugin to function. A follow-up task has been added at SPEC-3647 to further determine what we should do about it. For now, this adds a bbappend recipe and with it 2 patches that fixes trivial compilation errors. The third patch is for 'enhancing' the waltham protocol to pass from the transmitter plug-in to the receiver side the app_id. Bug-AGL: SPEC-3601, SPEC-3647 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: Ie01e4ad1db0a64d9d911308250ea63a79f78c6fa Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25452 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-graphical/recipes-graphics/wayland/waltham/0001-waltham-Fix-compile-build-error.patch')
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/waltham/0001-waltham-Fix-compile-build-error.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/waltham/0001-waltham-Fix-compile-build-error.patch b/meta-agl-profile-graphical/recipes-graphics/wayland/waltham/0001-waltham-Fix-compile-build-error.patch
new file mode 100644
index 000000000..354bcbc15
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/waltham/0001-waltham-Fix-compile-build-error.patch
@@ -0,0 +1,55 @@
+From cc87dddc2cdc0c20b053e3da1197efd671b4f50c Mon Sep 17 00:00:00 2001
+From: Marius Vlad <marius.vlad@collabora.com>
+Date: Wed, 23 Sep 2020 22:33:50 +0300
+Subject: [PATCH 1/2] waltham: Fix compile build error
+
+Newer compilers will complain about the fact debug_message is declared
+multiple times:
+
+multiple definition of `debug_message';
+.libs/marshaller.o:/home/mvlad/src/native-agl-weston8/waltham/waltham/src/waltham/marshaller_log.h:35:
+first defined here multiple definition of `debug_message';
+.libs/marshaller.o:/home/mvlad/src/native-agl-weston8/waltham/waltham/src/waltham/marshaller_log.h:35:
+first defined here /usr/bin/ld:
+.libs/client-serialice.o:/home/mvlad/src/native-agl-weston8/waltham/waltham/src/waltham/marshaller_log.h:35:
+multiple definition of `debug_message';
+.libs/marshaller.o:/home/mvlad/src/native-agl-weston8/waltham/waltham/src/waltham/marshaller_log.h:35:
+first defined here
+
+Bug-AGL: SPEC-3649
+
+Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
+---
+ src/waltham/marshaller_log.h | 2 +-
+ src/waltham/waltham-util.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/waltham/marshaller_log.h b/src/waltham/marshaller_log.h
+index 8254914..ffa87c1 100644
+--- a/src/waltham/marshaller_log.h
++++ b/src/waltham/marshaller_log.h
+@@ -32,7 +32,7 @@
+ /* Comment/uncomment to disable/enable debugging log */
+ #define DEBUG
+ //#define PROFILE
+-int debug_message;
++extern int debug_message;
+
+ #ifdef DEBUG
+ static inline void DEBUG_STAMP (void) {
+diff --git a/src/waltham/waltham-util.c b/src/waltham/waltham-util.c
+index 410b114..8f898f8 100644
+--- a/src/waltham/waltham-util.c
++++ b/src/waltham/waltham-util.c
+@@ -34,7 +34,7 @@
+ #include "waltham-connection.h"
+ #include "waltham-private.h"
+
+-int debug_message;
++extern int debug_message;
+
+ static void
+ wth_pfx_print(const char *pfx, const char *fmt, va_list argp)
+--
+2.28.0
+