summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/disable-sanitizer-tests.patch
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2018-11-13 22:33:07 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-12-07 19:23:04 +0000
commit7b56b77fc3e7aaac3bbd6174ac405db663001c76 (patch)
treec661182b4c884b1ef3eaaced47c48871b6b05b0d /meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/disable-sanitizer-tests.patch
parent283517aac75278dd5ccb63b90ab0f0a5a3fb1831 (diff)
Add weston-ivi-extension to meta-agl-profile-graphical
Add weston-ivi-extension recipe files removed from meta-agl-demo repository to meta-agl-profile-graphical layer. This allows using weston-ivi-extension in images other than agl-demo-platform. Bug-AGL: SPEC-1730 Change-Id: I08a6101484ac52fc2530b61390b7bd0b1bfa8f80 Signed-off-by: Scott Murray <scott.murray@konsulko.com> (cherry picked from commit 160b986d4afcccc47ee5e1c73ff4a57d6e341776)
Diffstat (limited to 'meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/disable-sanitizer-tests.patch')
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/disable-sanitizer-tests.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/disable-sanitizer-tests.patch b/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/disable-sanitizer-tests.patch
new file mode 100644
index 000000000..df5d616fd
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/disable-sanitizer-tests.patch
@@ -0,0 +1,13 @@
+Index: git/ivi-layermanagement-api/test/CMakeLists.txt
+===================================================================
+--- git.orig/ivi-layermanagement-api/test/CMakeLists.txt
++++ git/ivi-layermanagement-api/test/CMakeLists.txt
+@@ -58,7 +58,7 @@ IF(BUILD_ILM_API_TESTS)
+ )
+
+ SET(GCC_SANITIZER_COMPILE_FLAGS "-fsanitize=address -fsanitize=undefined -fno-sanitize-recover -fstack-protector-all")
+- SET( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${GCC_SANITIZER_COMPILE_FLAGS}" )
++ SET( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS}" )
+ SET( CMAKE_CXX_LINK_FLAGS "${CMAKE_CXX_LINK_FLAGS} -static-libasan -static-libubsan" )
+
+ ADD_EXECUTABLE(${PROJECT_NAME} ${SRC_FILES})