summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/test-path.patch
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2018-11-13 22:33:07 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-12-07 19:23:04 +0000
commit7b56b77fc3e7aaac3bbd6174ac405db663001c76 (patch)
treec661182b4c884b1ef3eaaced47c48871b6b05b0d /meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/test-path.patch
parent283517aac75278dd5ccb63b90ab0f0a5a3fb1831 (diff)
Add weston-ivi-extension to meta-agl-profile-graphical
Add weston-ivi-extension recipe files removed from meta-agl-demo repository to meta-agl-profile-graphical layer. This allows using weston-ivi-extension in images other than agl-demo-platform. Bug-AGL: SPEC-1730 Change-Id: I08a6101484ac52fc2530b61390b7bd0b1bfa8f80 Signed-off-by: Scott Murray <scott.murray@konsulko.com> (cherry picked from commit 160b986d4afcccc47ee5e1c73ff4a57d6e341776)
Diffstat (limited to 'meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/test-path.patch')
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/test-path.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/test-path.patch b/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/test-path.patch
new file mode 100644
index 000000000..251bc58f0
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/test-path.patch
@@ -0,0 +1,55 @@
+From fbe0d0fd35ff79561dc2da853f1b0903bfde428d Mon Sep 17 00:00:00 2001
+From: Changhyeok Bae <changhyeok.bae@gmail.com>
+Date: Thu, 1 Jun 2017 07:45:20 +0000
+Subject: [PATCH] test patch
+
+---
+ ivi-input-api/test/CMakeLists.txt | 9 +++++----
+ ivi-layermanagement-api/test/CMakeLists.txt | 7 ++++---
+ 2 files changed, 9 insertions(+), 7 deletions(-)
+
+diff --git a/ivi-input-api/test/CMakeLists.txt b/ivi-input-api/test/CMakeLists.txt
+index db05d0f..db3b745 100644
+--- a/ivi-input-api/test/CMakeLists.txt
++++ b/ivi-input-api/test/CMakeLists.txt
+@@ -65,12 +65,13 @@ IF(BUILD_ILM_API_TESTS)
+
+ ADD_DEPENDENCIES(${PROJECT_NAME} ${LIBS})
+
+- INSTALL(TARGETS ${PROJECT_NAME} DESTINATION bin)
++ INSTALL(TARGETS ${PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test)
++ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/CTestTestfile.cmake DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test/ivi-layermanagement-api)
+
+ # use CTest
+ ENABLE_TESTING()
+- ADD_TEST(ilmCommon ${PROJECT_NAME})
+- ADD_TEST(ilmControl ${PROJECT_NAME})
+- ADD_TEST(ilmInput ${PROJECT_NAME})
++ ADD_TEST(ilmCommon {CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
++ ADD_TEST(ilmControl {CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
++ ADD_TEST(ilmInput {CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
+
+ ENDIF()
+diff --git a/ivi-layermanagement-api/test/CMakeLists.txt b/ivi-layermanagement-api/test/CMakeLists.txt
+index fe9a0a4..090d734 100644
+--- a/ivi-layermanagement-api/test/CMakeLists.txt
++++ b/ivi-layermanagement-api/test/CMakeLists.txt
+@@ -63,11 +63,12 @@ IF(BUILD_ILM_API_TESTS)
+
+ ADD_DEPENDENCIES(${PROJECT_NAME} ${LIBS})
+
+- INSTALL(TARGETS ${PROJECT_NAME} DESTINATION bin)
++ INSTALL(TARGETS ${PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test)
++ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/CTestTestfile.cmake DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test/ivi-layermanagement-api)
+
+ # use CTest
+ ENABLE_TESTING()
+- ADD_TEST(ilmCommon ${PROJECT_NAME})
+- ADD_TEST(ilmControl ${PROJECT_NAME})
++ ADD_TEST(ilmCommon ${CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
++ ADD_TEST(ilmControl ${CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
+
+ ENDIF()
+--
+2.7.4
+