summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0009-ivi-shell-added-libweston-desktop-api_implementation.patch
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-02-21 16:37:55 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-02-21 16:37:55 +0100
commitdf4ed283e18f3dfe9f42f0012b12cb0af57bcdbb (patch)
tree40ad4b148e24c47d319bbbd23bbfc4af75a36e94 /meta-agl-profile-graphical/recipes-graphics/wayland/weston/0009-ivi-shell-added-libweston-desktop-api_implementation.patch
parentd40e55dbb362c455f0ee863b23c21ac2628cf3f8 (diff)
parent47aa65ba73e1b29459171de24fb0ee0040cbb39c (diff)
Merge remote-tracking branch 'agl/next'
* agl/next: meta-agl-bsp: Add CONFIG_LSM workaround for 5.1+ kernels meta-agl-profile-cluster-qt5: disable qtbase patches zeus updates for dragonboard-410c meta-security: activates dbus-cynagora recipes-graphics/wayland/weston: Expose weston_output_damage() meta-agl-profile-core: tweak udisks2 configuration for AGL meta-agl-bsp/meta-arago: update weston bbappend [RCAR] Update rcar driver weston 7 bsp 3.21.0 [RCAR] Update rcar driver weston 7 bsp 3.21.0 [RCAR] Split ADSP path for ulcb and ulcb-kf Fix nss-localuser post install meta-agl-bsp: meta-raspberrypi: handle zeus upgrade meta-agl-profile-core: add patch for systemd-udevd SECLABEL crash meta-security: disable dbus-cynara patches meta-agl-bsp: handle ptest-runner upgrade meta-agl-distro: Add inc file for next branch over-rides meta-agl-distro: BBMASK problematic upstream meta-security bbappend meta-agl-distro: prefer linux-yocto 4.19 LTS kernel meta-agl-profile-graphical-qt5: enable qt5location services meta-agl-profile-core: update most recipe meta-agl-profile-core: update neardal recipe Update base local.conf.sample meta-agl-profile-graphical: don't always build agl-compositor meta-agl-profile-graphical: update weston and weston-init meta-agl-profile-graphical: update wayland-ivi-extension for weston 7.0.0 meta-agl-distro: add polkit to DISTRO_FEATURES meta-agl-profile-core: update fontconfig bbappend meta-agl-profile-core: switch to udisks2 meta-security: handle systemd upgrade meta-agl-profile-graphical-qt5: handle qtwayland upgrade meta-agl-profile-core: handle freetype upgrade meta-agl-bsp meta-agl-profile-core: upgrade to opencv 4.x meta-agl-profile-core: update rtl-sdr recipe for zeus meta-security meta-app-framework: handle xmlsec1 upgrade meta-agl-profile-graphical: upgrade to gstreamer 1.16 meta-agl-profile-core: remove libmicrohttpd backport meta-agl-profile-core: remove backported curl and nghttp2 recipes meta-agl-profile-core: remove libnfc recipe meta-agl-profile-core: remove connman backport meta-agl-profile-graphical: remove weston 5.0.0 patches meta-agl-profile-core: remove old glibc patch meta-agl-bsp/meta-intel: remove linux-firmware_git.bbappend meta-agl-bsp: remove weston and wayland-protocols backports meta-app-framework: remove libzip recipe meta-security: remove keyutils recipe Declare layer compatibility with zeus Change-Id: Ie8ee1e37958279e7cf2d503c54ffacb46ba0c31c
Diffstat (limited to 'meta-agl-profile-graphical/recipes-graphics/wayland/weston/0009-ivi-shell-added-libweston-desktop-api_implementation.patch')
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/weston/0009-ivi-shell-added-libweston-desktop-api_implementation.patch166
1 files changed, 0 insertions, 166 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0009-ivi-shell-added-libweston-desktop-api_implementation.patch b/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0009-ivi-shell-added-libweston-desktop-api_implementation.patch
deleted file mode 100644
index 6a72f15d8..000000000
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0009-ivi-shell-added-libweston-desktop-api_implementation.patch
+++ /dev/null
@@ -1,166 +0,0 @@
-index 84db2c97..e797e4f9 100644
---- a/ivi-shell/ivi-shell.c
-+++ b/ivi-shell/ivi-shell.c
-@@ -489,6 +489,162 @@ shell_add_bindings(struct weston_compositor *compositor,
- shell);
- }
-
-+/*
-+ * libweston-desktop
-+ */
-+
-+static void
-+desktop_surface_ping_timeout(struct weston_desktop_client *client,
-+ void *user_data)
-+{
-+ weston_log("ivi-shell: desktop_surface_ping_timeout is not supported\n");
-+}
-+
-+static void
-+desktop_surface_pong(struct weston_desktop_client *client,
-+ void *user_data)
-+{
-+ weston_log("ivi-shell: desktop_surface_pong is not supported\n");
-+}
-+
-+static void
-+desktop_surface_added(struct weston_desktop_surface *surface,
-+ void *user_data)
-+{
-+ struct ivi_shell *shell = (struct ivi_shell *) user_data;
-+ struct ivi_layout_surface *layout_surface;
-+ struct ivi_shell_surface *ivisurf;
-+ struct weston_surface *weston_surf =
-+ weston_desktop_surface_get_surface(surface);
-+
-+ layout_surface = ivi_layout_desktop_surface_create(weston_surf,
-+ IVI_INVALID_ID);
-+ if (!layout_surface) {
-+ return;
-+ }
-+
-+ layout_surface->weston_desktop_surface = surface;
-+
-+ ivisurf = zalloc(sizeof *ivisurf);
-+ if (!ivisurf) {
-+ return;
-+ }
-+
-+ ivisurf->shell = shell;
-+ ivisurf->id_surface = IVI_INVALID_ID;
-+
-+ ivisurf->width = 0;
-+ ivisurf->height = 0;
-+ ivisurf->layout_surface = layout_surface;
-+ ivisurf->surface = weston_surf;
-+
-+ weston_desktop_surface_set_user_data(surface, ivisurf);
-+}
-+
-+static void
-+desktop_surface_removed(struct weston_desktop_surface *surface,
-+ void *user_data)
-+{
-+ struct ivi_shell_surface *ivisurf = (struct ivi_shell_surface *)
-+ weston_desktop_surface_get_user_data(surface);
-+
-+ assert(ivisurf != NULL);
-+
-+ if (ivisurf->layout_surface)
-+ layout_surface_cleanup(ivisurf);
-+}
-+
-+static void
-+desktop_surface_committed(struct weston_desktop_surface *surface,
-+ int32_t sx, int32_t sy, void *user_data)
-+{
-+ struct ivi_shell_surface *ivisurf = (struct ivi_shell_surface *)
-+ weston_desktop_surface_get_user_data(surface);
-+ struct weston_surface *weston_surf =
-+ weston_desktop_surface_get_surface(surface);
-+
-+ if(!ivisurf)
-+ return;
-+
-+ if (weston_surf->width == 0 || weston_surf->height == 0)
-+ return;
-+
-+ if (ivisurf->width != weston_surf->width ||
-+ ivisurf->height != weston_surf->height) {
-+ ivisurf->width = weston_surf->width;
-+ ivisurf->height = weston_surf->height;
-+
-+ ivi_layout_desktop_surface_configure(ivisurf->layout_surface,
-+ weston_surf->width,
-+ weston_surf->height);
-+ }
-+}
-+
-+static void
-+desktop_surface_move(struct weston_desktop_surface *surface,
-+ struct weston_seat *seat, uint32_t serial, void *user_data)
-+{
-+ weston_log("ivi-shell: desktop_surface_move is not supported\n");
-+}
-+
-+static void
-+desktop_surface_resize(struct weston_desktop_surface *surface,
-+ struct weston_seat *seat, uint32_t serial,
-+ enum weston_desktop_surface_edge edges, void *user_data)
-+{
-+ weston_log("ivi-shell: desktop_surface_resize is not supported\n");
-+}
-+
-+static void
-+desktop_surface_fullscreen_requested(struct weston_desktop_surface *surface,
-+ bool fullscreen,
-+ struct weston_output *output,
-+ void *user_data)
-+{
-+ weston_log("ivi-shell: desktop_surface_fullscreen_requested is not supported\n");
-+}
-+
-+static void
-+desktop_surface_maximized_requested(struct weston_desktop_surface *surface,
-+ bool maximized, void *user_data)
-+{
-+ weston_log("ivi-shell: desktop_surface_maximized_requested is not supported\n");
-+}
-+
-+static void
-+desktop_surface_minimized_requested(struct weston_desktop_surface *surface,
-+ void *user_data)
-+{
-+ weston_log("ivi-shell: desktop_surface_minimized_requested is not supported\n");
-+}
-+
-+static void
-+desktop_surface_set_xwayland_position(struct weston_desktop_surface *surface,
-+ int32_t x, int32_t y, void *user_data)
-+{
-+ weston_log("ivi-shell: desktop_surface_set_xwayland_position is not supported\n");
-+}
-+
-+static const struct weston_desktop_api shell_desktop_api = {
-+ .struct_size = sizeof(struct weston_desktop_api),
-+ .ping_timeout = desktop_surface_ping_timeout,
-+ .pong = desktop_surface_pong,
-+ .surface_added = desktop_surface_added,
-+ .surface_removed = desktop_surface_removed,
-+ .committed = desktop_surface_committed,
-+
-+ .move = desktop_surface_move,
-+ .resize = desktop_surface_resize,
-+ .fullscreen_requested = desktop_surface_fullscreen_requested,
-+ .maximized_requested = desktop_surface_maximized_requested,
-+ .minimized_requested = desktop_surface_minimized_requested,
-+ .set_xwayland_position = desktop_surface_set_xwayland_position,
-+};
-+
-+/*
-+ * end of libweston-desktop
-+ */
-+
- /*
- * Initialization of ivi-shell.
- */