summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical/recipes-graphics/wayland/weston_8.0.%.bbappend
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-05-25 15:01:08 -0400
committerScott Murray <scott.murray@konsulko.com>2020-05-26 14:35:39 +0000
commit30063de420b4f6c993dd3f2021ab84f622d69320 (patch)
tree5e28638cc9b04449b1131ff111c5a5e7937b23e2 /meta-agl-profile-graphical/recipes-graphics/wayland/weston_8.0.%.bbappend
parent10f6f30fdb15bdcd3707b3fc2e086782dd7aa69f (diff)
Cluster demo support updates
Changes include: - Add agl-weston-remoting feature that sets "weston-remoting" distro feature. The intent is to replace agl-gstrecorder in meta-agl-devel with something more generic. - Add weston remoting initialization timing patch to weston bbappend in meta-agl-profile-graphical, conditional on "weston-remoting" distro feature. - The 0004-unconditionally-include-mman.h.patch weston patch is no longer required after the SMACK labeling changes, remove it as cleanup. - Enable the weston "remoting" PACKAGECONFIG in weston bbappend, also conditional on "weston-remoting". A redefinition of the "remoting" PACKAGECONFIG option is required to fix a recipe bug that will have a fix sent upstream. - Rename virtualoutput.cfg weston.ini fragment to remote-output.cfg to better reflect its current contents. Bug-AGL: SPEC-3395 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I9c0579670d81296492b3b8bed93aafb3f7ffc15c Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/24567 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-graphical/recipes-graphics/wayland/weston_8.0.%.bbappend')
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/weston_8.0.%.bbappend6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston_8.0.%.bbappend b/meta-agl-profile-graphical/recipes-graphics/wayland/weston_8.0.%.bbappend
index bafd6bbcf..bada11c3f 100644
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/weston_8.0.%.bbappend
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/weston_8.0.%.bbappend
@@ -8,12 +8,16 @@ SRC_URI_append = "\
file://0001-Allow-regular-users-to-launch-Weston_7.0.0.patch \
file://0002-ivi-shell-Fix-crash-due-no-transmitter-screen.patch \
file://0001-libweston-Expose-weston_output_damage-in-libweston.patch \
- file://0004-unconditionally-include-mman.h.patch \
+ file://0004-main-change-remoting-initialization-timing.patch \
file://smack-weston \
"
EXTRA_OEMESON_append = " -Denable-user-start=true"
+# Workaround for incorrect upstream definition
+PACKAGECONFIG[remoting] = "-Dremoting=true,-Dremoting=false,gstreamer1.0 gstreamer1.0-plugins-base"
+PACKAGECONFIG_append = "${@bb.utils.contains('DISTRO_FEATURES', 'weston-remoting', ' remoting', '', d)}"
+
do_install_append() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'smack', 'true', 'false', d)}; then
# Install SMACK rules