summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical/recipes-graphics/wayland/weston_8.0.%.bbappend
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-05-07 15:55:04 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-05-12 23:34:44 +0000
commit4ee8c933aa9726f0493ead14b4e1c97a0844ec28 (patch)
tree59ce1ebb4080a4b0dc29b8e45023ce5b5ab44cf1 /meta-agl-profile-graphical/recipes-graphics/wayland/weston_8.0.%.bbappend
parent8b1baf589ebad0862791c32c7a9b953071dec20a (diff)
Add i.MX8MQ EVK support
Add imx8mqevk-viv machine template for i.MX8MQ EVK which uses the default Vivante driver configuration in meta-freescale with the new community linux-fslc-imx kernel. The following additional changes have been made to support this: - A linux-fslc-imx bbappend has been added to pull in the AGL kernel configuration, and a imx8mq-evkb config fragment has been added to enable the required Wifi driver for the updated EVKB board. - Stale qtbase and weston-init bbappends/patches have been removed from meta-agl-bsp/meta-freescale-layer. - The meta-agl-profile-graphical Weston 8.0.0 bbappend has been renamed to 8.0.% so the wildcard will apply it to meta-freescale's weston_8.0.0.imx recipe. Known issues: - The required PipeWire configuration for the onboard audio needs further investigation. Bug-AGL: SPEC-3258 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I4ea5437ef0ea8bedb9dd2157f2822ff25ee56cff
Diffstat (limited to 'meta-agl-profile-graphical/recipes-graphics/wayland/weston_8.0.%.bbappend')
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/weston_8.0.%.bbappend26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston_8.0.%.bbappend b/meta-agl-profile-graphical/recipes-graphics/wayland/weston_8.0.%.bbappend
new file mode 100644
index 000000000..bafd6bbcf
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/weston_8.0.%.bbappend
@@ -0,0 +1,26 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+# NOTE:
+# file://0003-compositor-drm-introduce-drm_get_dmafd_from_view.patch
+# has been removed until someone more familiar with weston internals
+# and waltham can take a look and update it.
+SRC_URI_append = "\
+ file://0001-Allow-regular-users-to-launch-Weston_7.0.0.patch \
+ file://0002-ivi-shell-Fix-crash-due-no-transmitter-screen.patch \
+ file://0001-libweston-Expose-weston_output_damage-in-libweston.patch \
+ file://0004-unconditionally-include-mman.h.patch \
+ file://smack-weston \
+ "
+
+EXTRA_OEMESON_append = " -Denable-user-start=true"
+
+do_install_append() {
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'smack', 'true', 'false', d)}; then
+ # Install SMACK rules
+ install -D -m 0644 ${WORKDIR}/smack-weston ${D}${sysconfdir}/smack/accesses.d/weston
+ fi
+}
+
+FILES_${PN} += "\
+ ${sysconfdir}/smack/accesses.d/* \
+"