summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical/recipes-graphics/wayland
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-01-22 20:26:42 -0500
committerScott Murray <scott.murray@konsulko.com>2020-01-22 20:26:42 -0500
commita1ff5158b4e59e02533454b5582edf084387ba3d (patch)
tree57aa4a9108019c172625104c43bf5eeafe3ae7ba /meta-agl-profile-graphical/recipes-graphics/wayland
parentcfc505308ebd6ef5cb972ae8a28b8089b168f4d1 (diff)
meta-agl-profile-graphical: update wayland-ivi-extension for weston 7.0.0
Tweak one patch to wayland-ivi-extension to handle switching from weston 6 to 7, and add another to handle the location of the plugin-registry.h header file having changed in weston 7. Bug-AGL: SPEC-2932 Change-Id: I6c861c593bbde24d4b18a88f1a42d87ac0450bfd Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-profile-graphical/recipes-graphics/wayland')
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0002-ivi-id-agent-added-ivi-id-agent.patch6
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0006-fix-plugin-registry-include.patch13
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension_git.bb1
3 files changed, 17 insertions, 3 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0002-ivi-id-agent-added-ivi-id-agent.patch b/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0002-ivi-id-agent-added-ivi-id-agent.patch
index 7deb01e99..d86e1f22e 100644
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0002-ivi-id-agent-added-ivi-id-agent.patch
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0002-ivi-id-agent-added-ivi-id-agent.patch
@@ -73,7 +73,7 @@ index 0000000..7354a7e
+pkg_check_modules(WAYLAND_SERVER wayland-server REQUIRED)
+pkg_check_modules(WESTON weston>=5.0.0 REQUIRED)
+pkg_check_modules(PIXMAN pixman-1 REQUIRED)
-+pkg_check_modules(LIBWESTON_DESKTOP libweston-desktop-6 REQUIRED)
++pkg_check_modules(LIBWESTON_DESKTOP libweston-desktop-7 REQUIRED)
+
+find_package(Threads REQUIRED)
+
@@ -149,8 +149,8 @@ index 0000000..9bc115d
+#include <limits.h>
+
+#include <weston.h>
-+#include <libweston-desktop.h>
-+#include "config-parser.h"
++#include <libweston-desktop/libweston-desktop.h>
++#include "libweston/config-parser.h"
+#include <weston/ivi-layout-export.h>
+
+#ifndef INVALID_ID
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0006-fix-plugin-registry-include.patch b/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0006-fix-plugin-registry-include.patch
new file mode 100644
index 000000000..dddbfd370
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension/0006-fix-plugin-registry-include.patch
@@ -0,0 +1,13 @@
+diff --git a/ivi-input-modules/ivi-input-controller/src/ivi-input-controller.c b/ivi-input-modules/ivi-input-controller/src/ivi-input-controller.c
+index a0bfc48..257a1dc 100644
+--- a/ivi-input-modules/ivi-input-controller/src/ivi-input-controller.c
++++ b/ivi-input-modules/ivi-input-controller/src/ivi-input-controller.c
+@@ -31,7 +31,7 @@
+ #include <fcntl.h>
+ #include <unistd.h>
+
+-#include "plugin-registry.h"
++#include <libweston/plugin-registry.h>
+ #include "ilm_types.h"
+
+ #include "ivi-input-server-protocol.h"
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension_git.bb b/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension_git.bb
index 3935929a5..68fc694a8 100644
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension_git.bb
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/wayland-ivi-extension_git.bb
@@ -12,6 +12,7 @@ SRC_URI = "git://github.com/GENIVI/${BPN}.git;protocol=http \
file://0002-add-LayerManagerControl-error-status.patch \
file://0004-ivi-ilmcontrol-added-focus-notification.patch \
file://0005-disable-EGLWLMockNavigation-example-build.patch \
+ file://0006-fix-plugin-registry-include.patch \
"
SRC_URI_append_wandboard = " file://wandboard_fix_build.patch"
SRCREV = "736fb654ac81230cf4f9e51a5772d3a02d7639bf"