summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical/recipes-platform
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-05-15 14:46:21 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-05-31 18:16:00 +0200
commitb43165328658087277b667152fdbc04fe07cba08 (patch)
treed1540adb65af28e41e9ebdfdbfe8b08470cb6887 /meta-agl-profile-graphical/recipes-platform
parentc40ee88f6aa0b379787a9ea3c853a806892e0dd1 (diff)
3rd part of the layer/profile rework [1/2]
This is the last larger commit in this series and deals with the graphical part. We introduce the graphical profiles: - meta-agl-profile-graphical -- meta-agl-profile-graphical-html5 -- meta-agl-profile-graphical-qt5 Notable changes: - weston-ini-conf moved to the meta-agl-bsp layer. Most BSPs have bbappends, so we need to have the recipes present (but unused) even in the console images. - new image: agl-image-boot = terminal-only + network + package-manaager. Ready for using package-feeds - new image/sdk: agl-image-minimal-crosssdk - agl-service-mediaplayer has a dependency on weston, thus it cannot be in the 'core'. Moved it to profile-graphical. - The wayland-ivi-extension moved to the agl-demo-platform. - The app-framework layer included and pulled 'web-runtime' as dependency. This broke console-only images. This has been moved to be in meta-agl-demo only for now. - added and massaged the agl-features. - found and added a useful script 'oe-depends-dot' that helps to work with the dot files (produced with bitbake -g) Todo: - we'll need another pass through the packagegroups. The dependencies for the layers/profiles are now sorted-out but we might have to add/shuffle a few packages. For further details, see meta-agl/docs/profiles.md. v2: fix meta-agl/meta-security/conf/layer.conf - the immediate expansion previously used in there caused some recipes not being added to BBFILES. v3: fix packagegroup renaming (packagegroup-agl-devel -> packagegroup-agl-core-devel) v4: fix missing packagegroup inclusion (tnx Jose, Scott, Stephane) v5: fix missing packagegroup inclusion v6: explicitely put profile-graphical-qt5 on-top of profile-graphical v7: re-add 'procps' when agl-devel feature is on Bug-AGL: SPEC-145 Change-Id: I24cdcd1118932758d0c55d333338238f2a770877 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-graphical/recipes-platform')
-rw-r--r--meta-agl-profile-graphical/recipes-platform/images/agl-image-weston.bb9
-rw-r--r--meta-agl-profile-graphical/recipes-platform/images/agl-image-weston.inc7
-rw-r--r--meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-graphical-services.bb14
-rw-r--r--meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-image-weston.bb22
-rw-r--r--meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-profile-graphical.bb20
5 files changed, 72 insertions, 0 deletions
diff --git a/meta-agl-profile-graphical/recipes-platform/images/agl-image-weston.bb b/meta-agl-profile-graphical/recipes-platform/images/agl-image-weston.bb
new file mode 100644
index 000000000..6c9bee7f1
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-platform/images/agl-image-weston.bb
@@ -0,0 +1,9 @@
+SUMMARY = "A very basic Wayland image with a terminal"
+
+require agl-image-weston.inc
+
+LICENSE = "MIT"
+
+IMAGE_INSTALL_append = "\
+ profile-agl-graphical \
+ "
diff --git a/meta-agl-profile-graphical/recipes-platform/images/agl-image-weston.inc b/meta-agl-profile-graphical/recipes-platform/images/agl-image-weston.inc
new file mode 100644
index 000000000..ed1634fcc
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-platform/images/agl-image-weston.inc
@@ -0,0 +1,7 @@
+require recipes-platform/images/agl-image-minimal.inc
+
+IMAGE_FEATURES += "splash package-management ssh-server-dropbear"
+
+inherit distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "wayland"
diff --git a/meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-graphical-services.bb b/meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-graphical-services.bb
new file mode 100644
index 000000000..b80089a94
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-graphical-services.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "The minimal set of packages for Connectivity Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-graphical-services \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+agl-service-mediaplayer \
+ "
diff --git a/meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-image-weston.bb b/meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-image-weston.bb
new file mode 100644
index 000000000..d622298c6
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-image-weston.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "The minimal set of packages required for basic Wayland image"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-image-weston \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += " \
+ weston \
+ weston-init \
+ weston-ini-conf \
+ weston-examples \
+ agl-login-manager \
+ agl-desktop-config \
+ packagegroup-agl-graphical-services \
+ profile-agl-minimal \
+ "
+
diff --git a/meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-profile-graphical.bb b/meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-profile-graphical.bb
new file mode 100644
index 000000000..46187fed3
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-profile-graphical.bb
@@ -0,0 +1,20 @@
+SUMMARY = "The middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required for AGL Distribution"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-profile-graphical \
+ profile-graphical \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ packagegroup-agl-image-minimal \
+ packagegroup-agl-image-weston \
+ packagegroup-agl-graphical-services \
+"
+
+RDEPENDS_profile-graphical = "${PN}"