summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2020-02-12 14:08:51 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-02-16 17:13:30 +0000
commit8787f82ce32a5fe42c56513ce32e8d1d94ce3e3e (patch)
treebea3b1adce3bc6a84e6a27092ce4137266fee5e4 /meta-agl-profile-graphical
parente32b0ddf6130dc5b62f86f1f588e6d1fa3b2d07a (diff)
recipes-graphics/wayland/weston: Expose weston_output_damage()
Seems that we can damage all the outputs, but not individual and output so patch libweston to include that declaration. The symbol's already exported. Bug-AGL: SPEC-3179 Change-Id: I6f765304c61d4ef288ebf015a131d9e138d50e97 Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Diffstat (limited to 'meta-agl-profile-graphical')
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/weston/0001-libweston-Expose-weston_output_damage-in-libweston.patch30
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/weston_7.0.0.bbappend1
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0001-libweston-Expose-weston_output_damage-in-libweston.patch b/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0001-libweston-Expose-weston_output_damage-in-libweston.patch
new file mode 100644
index 000000000..32755c4b3
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0001-libweston-Expose-weston_output_damage-in-libweston.patch
@@ -0,0 +1,30 @@
+From 7e5fb58591a29d60657158262a0772796bfd3461 Mon Sep 17 00:00:00 2001
+From: Marius Vlad <marius.vlad@collabora.com>
+Date: Wed, 12 Feb 2020 13:18:19 +0200
+Subject: [PATCH] libweston: Expose weston_output_damage() in libweston
+
+We have weston_compositor_damage_all() exported and declared but users
+might need weston_output_damage() to refer to an individual output. The
+symbol already exported so just declare it.
+
+Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
+---
+ include/libweston/libweston.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/include/libweston/libweston.h b/include/libweston/libweston.h
+index 1439775e..9fac5be0 100644
+--- a/include/libweston/libweston.h
++++ b/include/libweston/libweston.h
+@@ -1604,6 +1604,8 @@ weston_compositor_schedule_repaint(struct weston_compositor *compositor);
+ void
+ weston_compositor_damage_all(struct weston_compositor *compositor);
+ void
++weston_output_damage(struct weston_output *woutput);
++void
+ weston_compositor_wake(struct weston_compositor *compositor);
+ void
+ weston_compositor_sleep(struct weston_compositor *compositor);
+--
+2.20.1
+
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston_7.0.0.bbappend b/meta-agl-profile-graphical/recipes-graphics/wayland/weston_7.0.0.bbappend
index c2e52798d..67ce0ba5e 100644
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/weston_7.0.0.bbappend
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/weston_7.0.0.bbappend
@@ -9,6 +9,7 @@ SRC_URI_append = "\
file://use-XDG_RUNTIMESHARE_DIR.patch \
file://0002-ivi-shell-Fix-crash-due-no-transmitter-screen.patch \
file://0001-config-parser-Export-get_full_path-and-destroy.patch \
+ file://0001-libweston-Expose-weston_output_damage-in-libweston.patch \
"
EXTRA_OEMESON_append = " -Denable-user-start=true"