summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2019-05-14 16:11:58 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2019-06-14 09:22:13 +0000
commitde382e0eba1c57f2cd9a23323566754190b3a953 (patch)
treefa4c1bc7d6d1ec42307c743f9b4ce30e56c6ef94 /meta-agl-profile-graphical
parent512c821136dc6bf97f17f59ec32476eca280df8b (diff)
weston: Remove user session login for weston
Before that commit, the service weston was started as user 'display' with a full setup of the user. It means that all services normally started for user started for weston: systemd-user, dbus, afm-user-daemon, lightmediascanner (that is all at the moment). This is useless and grabs resources. This commit avoids to start a session for weston. This saves resources. This changes is part of a set of changes to run services as not root. Bug-AGL: SPEC-545 Bug-AGL: SPEC-2492 Change-Id: If51d8fdf8c5e19d10151a2b96a79dc01bbb8ccb4 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'meta-agl-profile-graphical')
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend b/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend
index 1ca63b5de..910cf5a67 100644
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend
@@ -2,6 +2,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
inherit agl-graphical
+
WESTONSTART ??= "/usr/bin/weston ${WESTONARGS}"
WESTONSTART_append = " ${@bb.utils.contains("IMAGE_FEATURES", "debug-tweaks", " --log=${DISPLAY_XDG_RUNTIME_DIR}/weston.log", "",d)}"
@@ -29,6 +30,7 @@ do_install_append() {
-e 's,ExecStart=.*,ExecStart=${WESTONSTART},g' \
-e 's,@WESTONTTY@,${WESTONTTY},g' \
-e 's,@XDG_RUNTIME_DIR@,${DISPLAY_XDG_RUNTIME_DIR},g' \
+ -e '/PAMName=/d' \
-i ${D}${systemd_system_unitdir}/weston.service
# Add a rule to ensure the 'display' user has permissions to