summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-telematics/recipes-platform
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-03-02 22:24:08 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-03-07 01:13:58 +0000
commitfd71c729ba03279cb9ad3a03290336afcae20bc0 (patch)
tree0638bf45264ff672564a2d0e6469c6d8eb6707b2 /meta-agl-profile-telematics/recipes-platform
parent0f4248d75dcb91a0cb351284d5a2daea6247d457 (diff)
Add basic telematics profile definition
Add base packagegroup and image definitions for the telematics profile. The basic agl-image-telematics image defined pulls in the application framework and the can-low-level and network bindings. Change-Id: Ifca8649da3ed3473361556cbdc578247f84fbefe Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-profile-telematics/recipes-platform')
-rw-r--r--meta-agl-profile-telematics/recipes-platform/images/agl-image-telematics.bb9
-rw-r--r--meta-agl-profile-telematics/recipes-platform/images/agl-image-telematics.inc5
-rw-r--r--meta-agl-profile-telematics/recipes-platform/packagegroups/packagegroup-agl-profile-telematics.bb25
3 files changed, 39 insertions, 0 deletions
diff --git a/meta-agl-profile-telematics/recipes-platform/images/agl-image-telematics.bb b/meta-agl-profile-telematics/recipes-platform/images/agl-image-telematics.bb
new file mode 100644
index 000000000..ad6ef9888
--- /dev/null
+++ b/meta-agl-profile-telematics/recipes-platform/images/agl-image-telematics.bb
@@ -0,0 +1,9 @@
+SUMMARY = "A basic telematics image"
+
+require agl-image-telematics.inc
+
+LICENSE = "MIT"
+
+IMAGE_INSTALL_append = "\
+ profile-telematics \
+ "
diff --git a/meta-agl-profile-telematics/recipes-platform/images/agl-image-telematics.inc b/meta-agl-profile-telematics/recipes-platform/images/agl-image-telematics.inc
new file mode 100644
index 000000000..b8c228cdc
--- /dev/null
+++ b/meta-agl-profile-telematics/recipes-platform/images/agl-image-telematics.inc
@@ -0,0 +1,5 @@
+require recipes-platform/images/agl-image-boot.inc
+
+inherit distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "3g"
diff --git a/meta-agl-profile-telematics/recipes-platform/packagegroups/packagegroup-agl-profile-telematics.bb b/meta-agl-profile-telematics/recipes-platform/packagegroups/packagegroup-agl-profile-telematics.bb
new file mode 100644
index 000000000..66fc0f765
--- /dev/null
+++ b/meta-agl-profile-telematics/recipes-platform/packagegroups/packagegroup-agl-profile-telematics.bb
@@ -0,0 +1,25 @@
+SUMMARY = "The middleware for AGL telematics profile"
+DESCRIPTION = "The set of packages required for AGL Telematics Distribution"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-profile-telematics \
+ profile-telematics \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ packagegroup-agl-image-boot \
+ packagegroup-agl-core-security \
+ ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','connman','connman connman-client','',d)} \
+ ${@bb.utils.contains("DISTRO_FEATURES", "3g", "libqmi", "", d)} \
+ agl-login-manager \
+ agl-service-can-low-level \
+ agl-service-network \
+ can-utils \
+"
+
+RDEPENDS_profile-telematics = "${PN}"