summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-connectivity
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2016-04-13 15:58:12 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2016-04-14 16:32:18 +0000
commitc407a33fe8d808e4c1c6a15a524de179e658c696 (patch)
tree3e855f411e91341195146aeca7de84f6ee3d8de1 /meta-agl/recipes-connectivity
parent0d4cff7d5839e501ab16f0dbe21c18620616d5b0 (diff)
Select networking manager with VIRTUAL-RUNTIME_net_manager at distro level
This variable allows to select the network manager daemon to use in the distro. Possible values are: systemd, connman. Later, it's possible to add other network daemons as well. Change-Id: I4085b4459d3ea110513f6ca9b921c5da92a7d745 Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
Diffstat (limited to 'meta-agl/recipes-connectivity')
-rw-r--r--meta-agl/recipes-connectivity/connman-ncurses/connman-ncurses_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-agl/recipes-connectivity/connman-ncurses/connman-ncurses_git.bb b/meta-agl/recipes-connectivity/connman-ncurses/connman-ncurses_git.bb
new file mode 100644
index 000000000..02afef75f
--- /dev/null
+++ b/meta-agl/recipes-connectivity/connman-ncurses/connman-ncurses_git.bb
@@ -0,0 +1,26 @@
+SUMMARY = "A simple ncurses interface for connman"
+DESCRIPTION = "A simple ncurses interface for connman"
+HOMEPAGE = "https://gitlab.com/iotbzh/connman-json-client"
+
+SECTION = "console/network"
+
+DEPENDS = "dbus ncurses connman json-c"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8c16666ae6c159876a0ba63099614381"
+
+SRC_URI = "git://gitlab.com/iotbzh/connman-json-client.git;protocol=https;rev=ad4261a2f87c914667b1f6841c913f6b08d373e2"
+
+inherit autotools pkgconfig
+
+EXTRA_AUTORECONF += " -i"
+EXTRA_OECONF += " --disable-optimization --enable-debug"
+
+S = "${WORKDIR}/git"
+
+do_install () {
+ install -dm755 ${D}${bindir}
+ install -Dm755 connman_ncurses ${D}${bindir}
+}
+
+FILES_${PN} = "${bindir}/connman_ncurses"