summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-core/systemd
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-16 22:14:52 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-20 17:07:06 +0200
commitbb0882c5dad030f676e424265ebcd869bb3ff899 (patch)
treed95bb2d7ad6b5ac47427f73babe015b0ade02342 /meta-agl/recipes-core/systemd
parent97e5e76efa44f55ee9aaf3998bb3df38b829706c (diff)
Introduce meta-agl-profile-core and meta-agl-profile-graphics
Rework towards agl profiles. This change is part of a series of changes to create the AGL profiles. This set will mainly introduce the 'core' profile. It is setup to be a drop-in change, thus some files were kept in (dummy) locations for now. However, they'll be taken care of in the next changes in this series. The main target of the meta-agl-profile-core layer is to host: - a minimal, bootable image with network and package management enabled -- agl-image-boot - a minimal image with network and packagemanagement and the AGL APIs -- agl-image-minimal The layer meta-agl-profile-graphical is used as superset of these and includes support for egl+wayland+weston. All recipes concerning graphics were moved there. This is not a full profile as we still have to migrate some parts of meta-agl-demo in a follow-up changeset. The roadmap as discussed during the F2F session in Karlsruhe is: - week 16 : core profile and profiles w/o graphics - week 17 : graphical profiles - week 18 : final conversion of the demo image v2: moved agl-login-manager from -graphics to -core (see Jose's comment) v3: moved back after discussion - follow-up in separate changeset Change-Id: Idacb0d1274baac1f63f8d1b850d4b1104ac33918 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl/recipes-core/systemd')
-rw-r--r--meta-agl/recipes-core/systemd/.appends.core0
-rw-r--r--meta-agl/recipes-core/systemd/systemd/0001-Switch-Smack-label-earlier.patch52
-rw-r--r--meta-agl/recipes-core/systemd/systemd/e2fsck.conf3
-rw-r--r--meta-agl/recipes-core/systemd/systemd/wired.network5
-rw-r--r--meta-agl/recipes-core/systemd/systemd_%.bbappend26
-rw-r--r--meta-agl/recipes-core/systemd/systemd_234.bbappend6
6 files changed, 0 insertions, 92 deletions
diff --git a/meta-agl/recipes-core/systemd/.appends.core b/meta-agl/recipes-core/systemd/.appends.core
deleted file mode 100644
index e69de29bb..000000000
--- a/meta-agl/recipes-core/systemd/.appends.core
+++ /dev/null
diff --git a/meta-agl/recipes-core/systemd/systemd/0001-Switch-Smack-label-earlier.patch b/meta-agl/recipes-core/systemd/systemd/0001-Switch-Smack-label-earlier.patch
deleted file mode 100644
index 46445be73..000000000
--- a/meta-agl/recipes-core/systemd/systemd/0001-Switch-Smack-label-earlier.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From 6cc74075797edb6f698cb7f312bb1c3d8cc6cb28 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Jos=C3=A9=20Bollo?= <jose.bollo@iot.bzh>
-Date: Thu, 12 Oct 2017 17:17:56 +0200
-Subject: [PATCH] Switch Smack label earlier
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Switching label after removing capability isn't
-possible.
-
-Change-Id: Ib7dac8f071f36119520ed3205d743c1e3df3cd5e
-Signed-off-by: José Bollo <jose.bollo@iot.bzh>
----
- src/core/execute.c | 14 +++++++-------
- 1 file changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/src/core/execute.c b/src/core/execute.c
-index d72e5bf08..0abffd569 100644
---- a/src/core/execute.c
-+++ b/src/core/execute.c
-@@ -2707,6 +2707,13 @@ static int exec_child(
- }
- }
-
-+ r = setup_smack(context, command);
-+ if (r < 0) {
-+ *exit_status = EXIT_SMACK_PROCESS_LABEL;
-+ *error_message = strdup("Failed to set SMACK process label");
-+ return r;
-+ }
-+
- if (!cap_test_all(context->capability_bounding_set)) {
- r = capability_bounding_set_drop(context->capability_bounding_set, false);
- if (r < 0) {
-@@ -2775,13 +2782,6 @@ static int exec_child(
- }
- #endif
-
-- r = setup_smack(context, command);
-- if (r < 0) {
-- *exit_status = EXIT_SMACK_PROCESS_LABEL;
-- *error_message = strdup("Failed to set SMACK process label");
-- return r;
-- }
--
- #ifdef HAVE_APPARMOR
- if (context->apparmor_profile && mac_apparmor_use()) {
- r = aa_change_onexec(context->apparmor_profile);
---
-2.14.3
-
diff --git a/meta-agl/recipes-core/systemd/systemd/e2fsck.conf b/meta-agl/recipes-core/systemd/systemd/e2fsck.conf
deleted file mode 100644
index b774f9ebf..000000000
--- a/meta-agl/recipes-core/systemd/systemd/e2fsck.conf
+++ /dev/null
@@ -1,3 +0,0 @@
-[options]
-# This will prevent e2fsck from stopping boot just because the clock is wrong
-broken_system_clock = 1
diff --git a/meta-agl/recipes-core/systemd/systemd/wired.network b/meta-agl/recipes-core/systemd/systemd/wired.network
deleted file mode 100644
index 3559b0155..000000000
--- a/meta-agl/recipes-core/systemd/systemd/wired.network
+++ /dev/null
@@ -1,5 +0,0 @@
-[Match]
-Name=eth* en*
-
-[Network]
-DHCP=yes
diff --git a/meta-agl/recipes-core/systemd/systemd_%.bbappend b/meta-agl/recipes-core/systemd/systemd_%.bbappend
deleted file mode 100644
index f64ca8c8a..000000000
--- a/meta-agl/recipes-core/systemd/systemd_%.bbappend
+++ /dev/null
@@ -1,26 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI += "\
- file://e2fsck.conf \
- ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','file://wired.network','',d)} \
-"
-
-# enable networkd/resolved support
-PACKAGECONFIG_append_pn-systemd = " \
- ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','networkd resolved','',d)} \
-"
-
-do_install_append() {
- # Install /etc/e2fsck.conf to avoid boot stuck by wrong clock time
- install -m 644 -p -D ${WORKDIR}/e2fsck.conf ${D}${sysconfdir}/e2fsck.conf
-
- if ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','true','false',d)}; then
- # Install DHCP configuration for Ethernet adapters
- install -m 644 ${WORKDIR}/wired.network ${D}${sysconfdir}/systemd/network
- fi
-}
-
-FILES_${PN} += "${sysconfdir}/e2fsck.conf "
-
-# SPEC-737: connmand also has a NTP client which races with systemd-timesyncd
-PACKAGECONFIG_remove = "timesyncd"
diff --git a/meta-agl/recipes-core/systemd/systemd_234.bbappend b/meta-agl/recipes-core/systemd/systemd_234.bbappend
deleted file mode 100644
index 4df7684d0..000000000
--- a/meta-agl/recipes-core/systemd/systemd_234.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI += "\
- file://0001-Switch-Smack-label-earlier.patch \
-"
-