summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-core
diff options
context:
space:
mode:
authorRonan <ronan.lemartret@iot.bzh>2017-01-20 16:55:46 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-03-03 18:01:43 +0000
commit3cfe59d1d10874fee11ee84f290406dd30a673bd (patch)
treec6e952dc31b04beaba3e69f2967fe3584db6a386 /meta-agl/recipes-core
parent36e8802fe16c939af3d5fadf20f7c5f9d98d368b (diff)
Add dependency to images
* [SPEC-424] * yocto image should use dependency to facilitate maintenance * yocto image should have its own LICENSE defined Change-Id: I47a6c35f5b80947c5ef8b4761dd98b4bc82a5507 Signed-off-by: Ronan <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-agl/recipes-core')
-rw-r--r--meta-agl/recipes-core/images/agl-image-minimal-qa.bb2
-rw-r--r--meta-agl/recipes-core/images/agl-image-minimal.bb10
-rw-r--r--meta-agl/recipes-core/images/agl-image-minimal.inc7
-rw-r--r--meta-agl/recipes-core/packagegroups/packagegroup-agl-image-minimal.bb (renamed from meta-agl/recipes-core/packagegroups/packagegroup-agl-core.bb)7
4 files changed, 17 insertions, 9 deletions
diff --git a/meta-agl/recipes-core/images/agl-image-minimal-qa.bb b/meta-agl/recipes-core/images/agl-image-minimal-qa.bb
index c5832f257..b162f2904 100644
--- a/meta-agl/recipes-core/images/agl-image-minimal-qa.bb
+++ b/meta-agl/recipes-core/images/agl-image-minimal-qa.bb
@@ -5,6 +5,8 @@ packages (e.g. commandline tools) for Quality Assurance(QA)."
require agl-image-minimal.bb
+LICENSE = "MIT"
+
IMAGE_INSTALL_append = " \
packagegroup-ivi-common-test \
"
diff --git a/meta-agl/recipes-core/images/agl-image-minimal.bb b/meta-agl/recipes-core/images/agl-image-minimal.bb
index 9648c6466..1fd213d0f 100644
--- a/meta-agl/recipes-core/images/agl-image-minimal.bb
+++ b/meta-agl/recipes-core/images/agl-image-minimal.bb
@@ -1,15 +1,9 @@
SUMMARY = "An AGL small image just capable of allowing a device to boot."
-IMAGE_INSTALL = "packagegroup-core-boot-agl ${ROOTFS_PKGMANAGE_BOOTSTRAP} ${CORE_IMAGE_EXTRA_INSTALL}"
-
-IMAGE_LINGUAS = " "
+require agl-image-minimal.inc
LICENSE = "MIT"
-inherit core-image
-
-IMAGE_ROOTFS_SIZE ?= "8192"
-
IMAGE_INSTALL_append = "\
- packagegroup-agl-core \
+ packagegroup-agl-image-minimal \
"
diff --git a/meta-agl/recipes-core/images/agl-image-minimal.inc b/meta-agl/recipes-core/images/agl-image-minimal.inc
new file mode 100644
index 000000000..2f127b36f
--- /dev/null
+++ b/meta-agl/recipes-core/images/agl-image-minimal.inc
@@ -0,0 +1,7 @@
+IMAGE_LINGUAS = " "
+
+inherit core-image
+
+IMAGE_INSTALL = "${ROOTFS_PKGMANAGE_BOOTSTRAP} ${CORE_IMAGE_EXTRA_INSTALL}"
+
+IMAGE_ROOTFS_SIZE ?= "8192"
diff --git a/meta-agl/recipes-core/packagegroups/packagegroup-agl-core.bb b/meta-agl/recipes-core/packagegroups/packagegroup-agl-image-minimal.bb
index 0dcc76464..630c11d43 100644
--- a/meta-agl/recipes-core/packagegroups/packagegroup-agl-core.bb
+++ b/meta-agl/recipes-core/packagegroups/packagegroup-agl-image-minimal.bb
@@ -4,12 +4,17 @@ LICENSE = "MIT"
inherit packagegroup
PACKAGES = "\
- packagegroup-agl-core \
+ packagegroup-agl-image-minimal \
"
ALLOW_EMPTY_${PN} = "1"
RDEPENDS_${PN} += "\
+ packagegroup-core-boot-agl \
+ "
+
+
+RDEPENDS_${PN} += "\
packagegroup-agl-core-automotive \
packagegroup-agl-core-connectivity \
packagegroup-agl-core-graphics \