summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-core
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2016-01-20 16:58:29 +0100
committerGerrit Code Review <gerrit@172.30.200.200>2016-01-21 21:18:18 +0000
commitb30c3e73bce8fbb473ea4f7f64a168edc24a2d0b (patch)
tree10b56079e26047678705903a21da2468e73ad2b3 /meta-agl/recipes-core
parent47e9e46cea8dd91b43f3f01605f0c165e3ea34e4 (diff)
improves install mode setting
When using install, the default mode value is 0755 that installs the files as executables. This patch removes that unexpected mode. Change-Id: I73e902a8907f98e94b5abaaf81d6c35ad98b0eb0 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'meta-agl/recipes-core')
-rw-r--r--meta-agl/recipes-core/dbus/dbus_%.bbappend6
-rw-r--r--meta-agl/recipes-core/systemd/systemd_%.bbappend2
2 files changed, 4 insertions, 4 deletions
diff --git a/meta-agl/recipes-core/dbus/dbus_%.bbappend b/meta-agl/recipes-core/dbus/dbus_%.bbappend
index 348be60c1..b27e44d99 100644
--- a/meta-agl/recipes-core/dbus/dbus_%.bbappend
+++ b/meta-agl/recipes-core/dbus/dbus_%.bbappend
@@ -9,9 +9,9 @@ inherit systemd
do_install_append() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -p -D ${WORKDIR}/dbus.service ${D}${systemd_user_unitdir}/dbus.service
- install -p -D ${WORKDIR}/dbus.socket ${D}${systemd_user_unitdir}/dbus.socket
- install -p -D ${WORKDIR}/dbus_env.conf ${D}${systemd_system_unitdir}/user@.service.d/dbus_env.conf
+ install -m 644 -p -D ${WORKDIR}/dbus.service ${D}${systemd_user_unitdir}/dbus.service
+ install -m 644 -p -D ${WORKDIR}/dbus.socket ${D}${systemd_user_unitdir}/dbus.socket
+ install -m 644 -p -D ${WORKDIR}/dbus_env.conf ${D}${systemd_system_unitdir}/user@.service.d/dbus_env.conf
# Execute these manually on behalf of systemctl script (from systemd-systemctl-native.bb)
# because it does not support systemd's user mode.
diff --git a/meta-agl/recipes-core/systemd/systemd_%.bbappend b/meta-agl/recipes-core/systemd/systemd_%.bbappend
index ef926953c..4e0d5d474 100644
--- a/meta-agl/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-agl/recipes-core/systemd/systemd_%.bbappend
@@ -7,7 +7,7 @@ PACKAGECONFIG_append_pn-systemd = " networkd"
do_install_append() {
# Install /etc/e2fsck.conf to avoid boot stuck by wrong clock time
- install -p -D ${WORKDIR}/e2fsck.conf ${D}/etc/e2fsck.conf
+ install -m 644 -p -D ${WORKDIR}/e2fsck.conf ${D}/etc/e2fsck.conf
}
FILES_${PN} += " /etc/e2fsck.conf "