summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-core
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2015-09-25 20:24:42 +0900
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2015-09-25 20:24:42 +0900
commite0cb14ae3f8eac1fb4c9c48b90e60115a0468985 (patch)
treebc490ec3f4d15e0bc6f1b045977244958db69d3b /meta-agl/recipes-core
parent6da592d11f2d3530ec84f1e5c42036eadb184605 (diff)
Add systemd configuration to launch psplash
Change-Id: I11c704890440b6412698c5067effcafb8b4849e8 Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Diffstat (limited to 'meta-agl/recipes-core')
-rw-r--r--meta-agl/recipes-core/psplash/files/psplash-quit.service11
-rw-r--r--meta-agl/recipes-core/psplash/files/psplash-start.service11
-rw-r--r--meta-agl/recipes-core/psplash/psplash_git.bbappend17
3 files changed, 38 insertions, 1 deletions
diff --git a/meta-agl/recipes-core/psplash/files/psplash-quit.service b/meta-agl/recipes-core/psplash/files/psplash-quit.service
new file mode 100644
index 000000000..14bd4994b
--- /dev/null
+++ b/meta-agl/recipes-core/psplash/files/psplash-quit.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Terminate Psplash Boot Screen
+After=psplash-start.service
+
+[Service]
+Type=oneshot
+ExecStart=/usr/bin/psplash-write QUIT
+TimeoutSec=20
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-agl/recipes-core/psplash/files/psplash-start.service b/meta-agl/recipes-core/psplash/files/psplash-start.service
new file mode 100644
index 000000000..7881e73cc
--- /dev/null
+++ b/meta-agl/recipes-core/psplash/files/psplash-start.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Start Psplash Boot Screen
+Wants=systemd-vconsole-setup.service
+After=systemd-vconsole-setup.service systemd-udev-trigger.service systemd-udevd.service
+DefaultDependencies=no
+
+[Service]
+ExecStart=/usr/bin/psplash -n
+
+[Install]
+WantedBy=sysinit.target
diff --git a/meta-agl/recipes-core/psplash/psplash_git.bbappend b/meta-agl/recipes-core/psplash/psplash_git.bbappend
index 193ecfb27..3b4f85102 100644
--- a/meta-agl/recipes-core/psplash/psplash_git.bbappend
+++ b/meta-agl/recipes-core/psplash/psplash_git.bbappend
@@ -1,10 +1,25 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI += "file://psplash-colors.h"
+SRC_URI += "file://psplash-colors.h \
+ file://psplash-start.service \
+ file://psplash-quit.service \
+ "
SPLASH_IMAGES="file://psplash-poky-img.h;outsuffix=default"
+inherit systemd
+
+SYSTEMD_PACKAGES = "${@base_contains('DISTRO_FEATURES', 'systemd', '${PN}', '', d)}"
+SYSTEMD_SERVICE_${PN} = "${@base_contains('DISTRO_FEATURES', 'systemd', 'psplash-start.service psplash-quit.service', '', d)}"
+
do_configure_append () {
cd ${S}
cp ../psplash-colors.h ./
}
+
+do_install_append () {
+ if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${systemd_unitdir}/system
+ install -m 644 ${WORKDIR}/*.service ${D}/${systemd_unitdir}/system
+ fi
+}