summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-graphics/wayland/weston/0015-window-client-remove-ivi-application-support.patch
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-16 22:14:52 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-20 17:07:06 +0200
commitbb0882c5dad030f676e424265ebcd869bb3ff899 (patch)
treed95bb2d7ad6b5ac47427f73babe015b0ade02342 /meta-agl/recipes-graphics/wayland/weston/0015-window-client-remove-ivi-application-support.patch
parent97e5e76efa44f55ee9aaf3998bb3df38b829706c (diff)
Introduce meta-agl-profile-core and meta-agl-profile-graphics
Rework towards agl profiles. This change is part of a series of changes to create the AGL profiles. This set will mainly introduce the 'core' profile. It is setup to be a drop-in change, thus some files were kept in (dummy) locations for now. However, they'll be taken care of in the next changes in this series. The main target of the meta-agl-profile-core layer is to host: - a minimal, bootable image with network and package management enabled -- agl-image-boot - a minimal image with network and packagemanagement and the AGL APIs -- agl-image-minimal The layer meta-agl-profile-graphical is used as superset of these and includes support for egl+wayland+weston. All recipes concerning graphics were moved there. This is not a full profile as we still have to migrate some parts of meta-agl-demo in a follow-up changeset. The roadmap as discussed during the F2F session in Karlsruhe is: - week 16 : core profile and profiles w/o graphics - week 17 : graphical profiles - week 18 : final conversion of the demo image v2: moved agl-login-manager from -graphics to -core (see Jose's comment) v3: moved back after discussion - follow-up in separate changeset Change-Id: Idacb0d1274baac1f63f8d1b850d4b1104ac33918 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl/recipes-graphics/wayland/weston/0015-window-client-remove-ivi-application-support.patch')
-rw-r--r--meta-agl/recipes-graphics/wayland/weston/0015-window-client-remove-ivi-application-support.patch130
1 files changed, 0 insertions, 130 deletions
diff --git a/meta-agl/recipes-graphics/wayland/weston/0015-window-client-remove-ivi-application-support.patch b/meta-agl/recipes-graphics/wayland/weston/0015-window-client-remove-ivi-application-support.patch
deleted file mode 100644
index f3d2fe47f..000000000
--- a/meta-agl/recipes-graphics/wayland/weston/0015-window-client-remove-ivi-application-support.patch
+++ /dev/null
@@ -1,130 +0,0 @@
-index c37cd00b..f30ddbe9 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -665,8 +665,6 @@ nodist_libtoytoolkit_la_SOURCES = \
- protocol/viewporter-client-protocol.h \
- protocol/xdg-shell-unstable-v6-protocol.c \
- protocol/xdg-shell-unstable-v6-client-protocol.h \
-- protocol/ivi-application-protocol.c \
-- protocol/ivi-application-client-protocol.h \
- protocol/pointer-constraints-unstable-v1-protocol.c \
- protocol/pointer-constraints-unstable-v1-client-protocol.h \
- protocol/relative-pointer-unstable-v1-protocol.c \
-diff --git a/clients/window.c b/clients/window.c
-index 95796d46..aac43abd 100644
---- a/clients/window.c
-+++ b/clients/window.c
-@@ -82,10 +82,6 @@ typedef void *EGLContext;
-
- #include "window.h"
-
--#include <sys/types.h>
--#include "ivi-application-client-protocol.h"
--#define IVI_SURFACE_ID 9000
--
- #define ZWP_RELATIVE_POINTER_MANAGER_V1_VERSION 1
- #define ZWP_POINTER_CONSTRAINTS_V1_VERSION 1
-
-@@ -107,7 +103,6 @@ struct display {
- struct wl_data_device_manager *data_device_manager;
- struct text_cursor_position *text_cursor_position;
- struct zxdg_shell_v6 *xdg_shell;
-- struct ivi_application *ivi_application; /* ivi style shell */
- struct zwp_relative_pointer_manager_v1 *relative_pointer_manager;
- struct zwp_pointer_constraints_v1 *pointer_constraints;
- EGLDisplay dpy;
-@@ -269,8 +264,6 @@ struct window {
- struct window *parent;
- struct window *last_parent;
-
-- struct ivi_surface *ivi_surface;
--
- struct window_frame *frame;
-
- /* struct surface::link, contains also main_surface */
-@@ -1441,19 +1434,6 @@ window_get_display(struct window *window)
- return window->display;
- }
-
--static void
--handle_ivi_surface_configure(void *data, struct ivi_surface *ivi_surface,
-- int32_t width, int32_t height)
--{
-- struct window *window = data;
--
-- window_schedule_resize(window, width, height);
--}
--
--static const struct ivi_surface_listener ivi_surface_listener = {
-- handle_ivi_surface_configure,
--};
--
- static void
- surface_create_surface(struct surface *surface, uint32_t flags)
- {
-@@ -1604,9 +1584,6 @@ window_destroy(struct window *window)
- if (window->xdg_surface)
- zxdg_surface_v6_destroy(window->xdg_surface);
-
-- if (window->ivi_surface)
-- ivi_surface_destroy(window->ivi_surface);
--
- surface_destroy(window->main_surface);
-
- wl_list_remove(&window->link);
-@@ -5200,7 +5177,7 @@ window_create_internal(struct display *display, int custom)
- surface = surface_create(window);
- window->main_surface = surface;
-
-- assert(custom || display->xdg_shell || display->ivi_application);
-+ assert(custom || display->xdg_shell);
-
- window->custom = custom;
- window->preferred_format = WINDOW_PREFERRED_FORMAT_NONE;
-@@ -5220,7 +5197,6 @@ struct window *
- window_create(struct display *display)
- {
- struct window *window;
-- uint32_t id_ivisurf;
-
- window = window_create_internal(display, 0);
-
-@@ -5243,16 +5219,6 @@ window_create(struct display *display)
- window_inhibit_redraw(window);
-
- wl_surface_commit(window->main_surface->surface);
-- } else if (display->ivi_application) {
-- /* auto generation of ivi_id based on process id + basement of id */
-- id_ivisurf = IVI_SURFACE_ID + (uint32_t)getpid();
-- window->ivi_surface =
-- ivi_application_surface_create(display->ivi_application,
-- id_ivisurf, window->main_surface->surface);
-- fail_on_null(window->ivi_surface, 0, __FILE__, __LINE__);
--
-- ivi_surface_add_listener(window->ivi_surface,
-- &ivi_surface_listener, window);
- }
-
- return window;
-@@ -6013,11 +5979,6 @@ registry_handle_global(void *data, struct wl_registry *registry, uint32_t id,
- wl_registry_bind(registry, id,
- &wl_subcompositor_interface, 1);
- }
-- else if (strcmp(interface, "ivi_application") == 0) {
-- d->ivi_application =
-- wl_registry_bind(registry, id,
-- &ivi_application_interface, 1);
-- }
-
- if (d->global_handler)
- d->global_handler(d, id, interface, version, d->user_data);
-@@ -6316,9 +6277,6 @@ display_destroy(struct display *display)
- if (display->xdg_shell)
- zxdg_shell_v6_destroy(display->xdg_shell);
-
-- if (display->ivi_application)
-- ivi_application_destroy(display->ivi_application);
--
- if (display->shm)
- wl_shm_destroy(display->shm);
-