summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-graphics
diff options
context:
space:
mode:
authorChanghyeok Bae <changhyeok.bae@gmail.com>2017-05-31 07:11:31 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-06-02 00:57:36 +0000
commit0ea9f9fd830ec1e9a5bc776cac7a9cab7c452a24 (patch)
tree19453d2e0e0ff7f3c71fda908f5aaf7e07570ac2 /meta-agl/recipes-graphics
parent5a63eef23be9adb662a4dac8f13f7d64fd4ef673 (diff)
agl-login-manager,agl-desktop-config: Move layer to meta-agl
agl-ivi-image is using agl-login-manager and agl-desktop-config. However, those aren't included in meta-agl layer. So agl-ivi-image isn't built only with meta-agl layer. Bug-AGL: SPEC-625 Change-Id: Ied4bbec9c72d2f7cac5b01c2465fe395c2e5497c Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/9587 Reviewed-by: Martin Kelly <mkelly@xevo.com> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Diffstat (limited to 'meta-agl/recipes-graphics')
-rw-r--r--meta-agl/recipes-graphics/agl-desktop-config/agl-desktop-config_0.1.bb21
-rw-r--r--meta-agl/recipes-graphics/agl-desktop-config/files/user-weston-term.path8
-rw-r--r--meta-agl/recipes-graphics/agl-desktop-config/files/user-weston-term.service12
3 files changed, 41 insertions, 0 deletions
diff --git a/meta-agl/recipes-graphics/agl-desktop-config/agl-desktop-config_0.1.bb b/meta-agl/recipes-graphics/agl-desktop-config/agl-desktop-config_0.1.bb
new file mode 100644
index 000000000..e0358d615
--- /dev/null
+++ b/meta-agl/recipes-graphics/agl-desktop-config/agl-desktop-config_0.1.bb
@@ -0,0 +1,21 @@
+SUMMARY = "AGL desktop config"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI += " \
+ file://user-weston-term.service \
+ file://user-weston-term.path \
+"
+
+do_install_append() {
+ install -d ${D}${systemd_user_unitdir}
+ install -m 0644 ${WORKDIR}/user-weston-term.service ${D}${systemd_user_unitdir}
+ install -m 0644 ${WORKDIR}/user-weston-term.path ${D}${systemd_user_unitdir}
+
+ install -d ${D}${systemd_user_unitdir}/default.target.wants
+ ln -sf ${systemd_user_unitdir}/user-weston-term.path ${D}${libdir}/systemd/user/default.target.wants
+}
+
+FILES_${PN} += "${systemd_user_unitdir}/*"
+FILES_${PN} += "${systemd_user_unitdir}/default.target.wants/default.target.wants"
diff --git a/meta-agl/recipes-graphics/agl-desktop-config/files/user-weston-term.path b/meta-agl/recipes-graphics/agl-desktop-config/files/user-weston-term.path
new file mode 100644
index 000000000..9481840e5
--- /dev/null
+++ b/meta-agl/recipes-graphics/agl-desktop-config/files/user-weston-term.path
@@ -0,0 +1,8 @@
+[Unit]
+Description=Terminal for weston user unit path
+
+[Path]
+PathExists=%t/wayland-0
+
+[Install]
+WantedBy=default.target
diff --git a/meta-agl/recipes-graphics/agl-desktop-config/files/user-weston-term.service b/meta-agl/recipes-graphics/agl-desktop-config/files/user-weston-term.service
new file mode 100644
index 000000000..ad8b9583b
--- /dev/null
+++ b/meta-agl/recipes-graphics/agl-desktop-config/files/user-weston-term.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Terminal for weston user
+After=user-config.service
+Requires=user-config.service
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/weston-terminal
+Restart=always
+
+[Install]
+WantedBy=multi-user.target