summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-graphics
diff options
context:
space:
mode:
authorRonan <ronan.lemartret@iot.bzh>2017-01-20 16:55:46 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-03-03 18:01:43 +0000
commit3cfe59d1d10874fee11ee84f290406dd30a673bd (patch)
treec6e952dc31b04beaba3e69f2967fe3584db6a386 /meta-agl/recipes-graphics
parent36e8802fe16c939af3d5fadf20f7c5f9d98d368b (diff)
Add dependency to images
* [SPEC-424] * yocto image should use dependency to facilitate maintenance * yocto image should have its own LICENSE defined Change-Id: I47a6c35f5b80947c5ef8b4761dd98b4bc82a5507 Signed-off-by: Ronan <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-agl/recipes-graphics')
-rw-r--r--meta-agl/recipes-graphics/images/agl-image-weston.bb10
-rw-r--r--meta-agl/recipes-graphics/images/agl-image-weston.inc7
-rw-r--r--meta-agl/recipes-graphics/packagegroups/packagegroup-agl-image-weston.bb16
3 files changed, 27 insertions, 6 deletions
diff --git a/meta-agl/recipes-graphics/images/agl-image-weston.bb b/meta-agl/recipes-graphics/images/agl-image-weston.bb
index a5475222d..bc449795d 100644
--- a/meta-agl/recipes-graphics/images/agl-image-weston.bb
+++ b/meta-agl/recipes-graphics/images/agl-image-weston.bb
@@ -1,11 +1,9 @@
SUMMARY = "A very basic Wayland image with a terminal"
-IMAGE_FEATURES += "splash package-management ssh-server-dropbear"
+require agl-image-weston.inc
LICENSE = "MIT"
-inherit core-image distro_features_check
-
-REQUIRED_DISTRO_FEATURES = "wayland"
-
-CORE_IMAGE_BASE_INSTALL += "weston weston-examples"
+IMAGE_INSTALL_append = "\
+ packagegroup-agl-image-weston \
+ "
diff --git a/meta-agl/recipes-graphics/images/agl-image-weston.inc b/meta-agl/recipes-graphics/images/agl-image-weston.inc
new file mode 100644
index 000000000..947d22b50
--- /dev/null
+++ b/meta-agl/recipes-graphics/images/agl-image-weston.inc
@@ -0,0 +1,7 @@
+require recipes-core/images/agl-image-minimal.inc
+
+IMAGE_FEATURES += "splash package-management ssh-server-dropbear"
+
+inherit distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "wayland"
diff --git a/meta-agl/recipes-graphics/packagegroups/packagegroup-agl-image-weston.bb b/meta-agl/recipes-graphics/packagegroups/packagegroup-agl-image-weston.bb
new file mode 100644
index 000000000..c92c60f90
--- /dev/null
+++ b/meta-agl/recipes-graphics/packagegroups/packagegroup-agl-image-weston.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "The minimal set of packages required for basic Wayland image"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-image-weston \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "weston weston-examples"
+
+RDEPENDS_${PN} += "\
+ packagegroup-agl-image-minimal \
+ "