summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-graphics
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2015-12-11 17:01:05 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2015-12-11 17:08:48 +0000
commit5f0335b7b1935387a827c86c3cc5286ed28d0c72 (patch)
tree14fb03bfeb0e6187d275447a909f3954aba9208d /meta-agl/recipes-graphics
parent019682fca4a5a9754276dff79d5c2ab859e0cc40 (diff)
Fix the recipe of weston
To suit systemd.bbclass and poky-agl.conf, recipe of weston has been fixed. Change-Id: I9b401748176d0afdf5f8566b6e126416bb9d79d8 Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Diffstat (limited to 'meta-agl/recipes-graphics')
-rw-r--r--meta-agl/recipes-graphics/wayland/weston_1.5.0.bbappend13
1 files changed, 7 insertions, 6 deletions
diff --git a/meta-agl/recipes-graphics/wayland/weston_1.5.0.bbappend b/meta-agl/recipes-graphics/wayland/weston_1.5.0.bbappend
index c982ed5de..7167388d4 100644
--- a/meta-agl/recipes-graphics/wayland/weston_1.5.0.bbappend
+++ b/meta-agl/recipes-graphics/wayland/weston_1.5.0.bbappend
@@ -8,13 +8,15 @@ SRC_URI_append = "\
"
inherit systemd
-DEPENDS_append = " systemd"
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "weston.service"
do_install_append() {
- mkdir -p ${D}${systemd_unitdir}/system/
- cp ${WORKDIR}/weston.service ${D}${systemd_unitdir}/system/
- mkdir -p ${D}${systemd_unitdir}/system/multi-user.target.wants/
- ln -sf /lib/systemd/system/weston.service ${D}/${systemd_unitdir}/system/multi-user.target.wants/weston.service
+ # Install systemd unit files
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ install -p -D ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
+ fi
WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
install -d ${D}${WESTON_INI_CONFIG}
@@ -22,6 +24,5 @@ do_install_append() {
}
FILES_${PN} += " \
- ${systemd_unitdir}/system/* \
${sysconfdir}/xdg/weston/weston.ini \
"