summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-graphics
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2016-01-20 16:58:29 +0100
committerGerrit Code Review <gerrit@172.30.200.200>2016-01-21 21:18:18 +0000
commitb30c3e73bce8fbb473ea4f7f64a168edc24a2d0b (patch)
tree10b56079e26047678705903a21da2468e73ad2b3 /meta-agl/recipes-graphics
parent47e9e46cea8dd91b43f3f01605f0c165e3ea34e4 (diff)
improves install mode setting
When using install, the default mode value is 0755 that installs the files as executables. This patch removes that unexpected mode. Change-Id: I73e902a8907f98e94b5abaaf81d6c35ad98b0eb0 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'meta-agl/recipes-graphics')
-rw-r--r--meta-agl/recipes-graphics/wayland/weston_%.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-agl/recipes-graphics/wayland/weston_%.bbappend b/meta-agl/recipes-graphics/wayland/weston_%.bbappend
index 2ee7150e5..6ad42fc77 100644
--- a/meta-agl/recipes-graphics/wayland/weston_%.bbappend
+++ b/meta-agl/recipes-graphics/wayland/weston_%.bbappend
@@ -13,7 +13,7 @@ SYSTEMD_SERVICE_${PN} = "weston.service"
do_install_append() {
# Install systemd unit files
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -p -D ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
+ install -m 644 -p -D ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
fi
WESTON_INI_CONFIG=${sysconfdir}/xdg/weston