summaryrefslogtreecommitdiffstats
path: root/meta-agl
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2018-03-23 11:10:30 +0100
committerronan Le Martret <ronan.lemartret@iot.bzh>2018-03-27 09:32:40 +0000
commit3432bfd14f3644d947f629243da2ceadece37b97 (patch)
treef91f575beed4a365cf10bb1d20c2ad03ea8ffa79 /meta-agl
parentf76255eb84830a981c2539b2706d8c4ec9134939 (diff)
Add bluez-alsa recipes to AGL
* Bluez-alsa allows to use a bluetooth audio device with alsa without pulse audio * BlueALSA registers all known Bluetooth audio profiles in Bluez. * Bluez-alsa is optional in AGL. * 4a audio feature will enable it.(4a audio can be pulseaudio free). Bug-AGL: SPEC-1342 Change-Id: I858fbb795b3c7859ac1e536c14305fde7bf94b62 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-agl')
-rw-r--r--meta-agl/recipes-connectivity/bluez-alsa/bluez-alsa_git.bb38
-rw-r--r--meta-agl/recipes-connectivity/bluez-alsa/files/bluez-alsa.service11
2 files changed, 49 insertions, 0 deletions
diff --git a/meta-agl/recipes-connectivity/bluez-alsa/bluez-alsa_git.bb b/meta-agl/recipes-connectivity/bluez-alsa/bluez-alsa_git.bb
new file mode 100644
index 000000000..6379ec38f
--- /dev/null
+++ b/meta-agl/recipes-connectivity/bluez-alsa/bluez-alsa_git.bb
@@ -0,0 +1,38 @@
+SUMMARY = "Bluetooth Audio ALSA Backend"
+HOMEPAGE = "https://github.com/Arkq/bluez-alsa"
+SECTION = "libs"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=bb3e99e80c5d718213f35ae1def4c106"
+
+SRC_URI = "git://github.com/Arkq/bluez-alsa.git;protocol=https;branch=master"
+SRCREV = "9045edb436ea755f395a2e09e4525b5defad286a"
+
+SRC_URI += "file://bluez-alsa.service"
+
+S = "${WORKDIR}/git"
+
+DEPENDS += "alsa-lib bluez5 systemd glib-2.0 sbc"
+
+PACKAGECONFIG[aac] = "--enable-aac, --disable-aac, "
+PACKAGECONFIG[aptx] = "--enable-aptx,--disable-aptx,"
+PACKAGECONFIG[hcitop] = "--enable-hcitop, --disable-hcitop, libbsd ncurses"
+
+inherit autotools pkgconfig
+inherit systemd
+
+SYSTEMD_AUTO_ENABLE = "enable"
+SYSTEMD_SERVICE_${PN} = "bluez-alsa.service"
+
+PACKAGECONFIG += "hcitop"
+
+do_install_append () {
+ install -d ${D}${base_libdir}/systemd/system
+ install -m 0644 ${WORKDIR}/bluez-alsa.service ${D}${base_libdir}/systemd/system
+}
+
+FILES_${PN} += "\
+ ${datadir}/alsa/alsa.conf.d/20-bluealsa.conf\
+ ${libdir}/alsa-lib/libasound_module_ctl_bluealsa.so\
+ ${libdir}/alsa-lib/libasound_module_pcm_bluealsa.so\
+"
diff --git a/meta-agl/recipes-connectivity/bluez-alsa/files/bluez-alsa.service b/meta-agl/recipes-connectivity/bluez-alsa/files/bluez-alsa.service
new file mode 100644
index 000000000..671815e03
--- /dev/null
+++ b/meta-agl/recipes-connectivity/bluez-alsa/files/bluez-alsa.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Bluetooth Audio ALSA Backend
+After=bluetooth.service
+Requires=bluetooth.service
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/bluealsa
+
+[Install]
+WantedBy=multi-user.target