summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-devtools
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-02 17:10:51 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-11-20 00:33:16 +0000
commitbad73bf315325c3428e331984f9d17bb8b2873b3 (patch)
treef1af509d2d534d7232ab63304faf52e549fbaeca /meta-app-framework/recipes-devtools
parent5f1d801530f9b3d7f99826b4cc8cc23df77d1e42 (diff)
Convert to new override syntax
This is effectively a manual cherry-pick and squash of commits: dd6fc5dcaa0a027b7651bb365d5dd0f623498f8f 917a82316bf53ead29d6345a39189d9e4efeef25 20e81c0a9d36660de671dd5ac2e006e31c0e621b from the master branch with additional review and fixups. The intent of these changes is to minimize the effort to backport fixes from the master branch, which has been updated in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4144 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I91c1640c6335d7748a2531d2fe8bf86d2d2aee32 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26876 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-app-framework/recipes-devtools')
-rw-r--r--meta-app-framework/recipes-devtools/cmake-apps-module/cmake-apps-module_git.bb2
-rw-r--r--meta-app-framework/recipes-devtools/json-c/json-c_appfw.inc2
-rw-r--r--meta-app-framework/recipes-devtools/libafb-helpers/libafb-helpers_git.bb4
-rw-r--r--meta-app-framework/recipes-devtools/libafb-helpers/libafb-helpers_git.inc2
-rw-r--r--meta-app-framework/recipes-devtools/libappcontroller/libappcontroller_git.bb6
-rw-r--r--meta-app-framework/recipes-devtools/packagegroups/nativesdk-packagegroup-sdk-host_appfw.inc2
-rw-r--r--meta-app-framework/recipes-devtools/run-postinsts/run-postinsts_appfw.inc8
7 files changed, 13 insertions, 13 deletions
diff --git a/meta-app-framework/recipes-devtools/cmake-apps-module/cmake-apps-module_git.bb b/meta-app-framework/recipes-devtools/cmake-apps-module/cmake-apps-module_git.bb
index 3fea2ed91..4164171ff 100644
--- a/meta-app-framework/recipes-devtools/cmake-apps-module/cmake-apps-module_git.bb
+++ b/meta-app-framework/recipes-devtools/cmake-apps-module/cmake-apps-module_git.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}/git"
inherit cmake
-FILES_${PN} += " ${datadir}/*/Modules/CMakeAfbTemplates*"
+FILES:${PN} += " ${datadir}/*/Modules/CMakeAfbTemplates*"
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-app-framework/recipes-devtools/json-c/json-c_appfw.inc b/meta-app-framework/recipes-devtools/json-c/json-c_appfw.inc
index f1547e14b..c15548c55 100644
--- a/meta-app-framework/recipes-devtools/json-c/json-c_appfw.inc
+++ b/meta-app-framework/recipes-devtools/json-c/json-c_appfw.inc
@@ -1 +1 @@
-EXTRA_OECONF_append = " --enable-threading"
+EXTRA_OECONF:append = " --enable-threading"
diff --git a/meta-app-framework/recipes-devtools/libafb-helpers/libafb-helpers_git.bb b/meta-app-framework/recipes-devtools/libafb-helpers/libafb-helpers_git.bb
index 1174ac4d7..9ca32fdda 100644
--- a/meta-app-framework/recipes-devtools/libafb-helpers/libafb-helpers_git.bb
+++ b/meta-app-framework/recipes-devtools/libafb-helpers/libafb-helpers_git.bb
@@ -2,7 +2,7 @@ require libafb-helpers_git.inc
inherit cmake
-RDEPENDS_${PN}_append = " af-binder"
+RDEPENDS:${PN}:append = " af-binder"
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
diff --git a/meta-app-framework/recipes-devtools/libafb-helpers/libafb-helpers_git.inc b/meta-app-framework/recipes-devtools/libafb-helpers/libafb-helpers_git.inc
index 6753225b4..6da093237 100644
--- a/meta-app-framework/recipes-devtools/libafb-helpers/libafb-helpers_git.inc
+++ b/meta-app-framework/recipes-devtools/libafb-helpers/libafb-helpers_git.inc
@@ -10,5 +10,5 @@ SRCREV = "1d1c6cef6039effd4c045a76d30414b589336d0e"
PV = "${AGLVERSION}"
S = "${WORKDIR}/git"
-DEPENDS_append = " af-binder jq"
+DEPENDS:append = " af-binder jq"
diff --git a/meta-app-framework/recipes-devtools/libappcontroller/libappcontroller_git.bb b/meta-app-framework/recipes-devtools/libappcontroller/libappcontroller_git.bb
index 0ee9c5e84..74fe08144 100644
--- a/meta-app-framework/recipes-devtools/libappcontroller/libappcontroller_git.bb
+++ b/meta-app-framework/recipes-devtools/libappcontroller/libappcontroller_git.bb
@@ -10,10 +10,10 @@ SRCREV = "1bef31c8bbad27f4914484c5007b2e199fb073d4"
PV = "${AGLVERSION}"
S = "${WORKDIR}/git"
-DEPENDS_append = " af-binder libafb-helpers lua"
-RDEPENDS_${PN}_append = " af-binder lua"
+DEPENDS:append = " af-binder libafb-helpers lua"
+RDEPENDS:${PN}:append = " af-binder lua"
inherit cmake
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
diff --git a/meta-app-framework/recipes-devtools/packagegroups/nativesdk-packagegroup-sdk-host_appfw.inc b/meta-app-framework/recipes-devtools/packagegroups/nativesdk-packagegroup-sdk-host_appfw.inc
index 8d6ffb5b3..27ee7cf52 100644
--- a/meta-app-framework/recipes-devtools/packagegroups/nativesdk-packagegroup-sdk-host_appfw.inc
+++ b/meta-app-framework/recipes-devtools/packagegroups/nativesdk-packagegroup-sdk-host_appfw.inc
@@ -1,4 +1,4 @@
-RDEPENDS_${PN}_append = " \
+RDEPENDS:${PN}:append = " \
nativesdk-af-main-tools \
nativesdk-af-binder-devtools \
nativesdk-cmake-apps-module \
diff --git a/meta-app-framework/recipes-devtools/run-postinsts/run-postinsts_appfw.inc b/meta-app-framework/recipes-devtools/run-postinsts/run-postinsts_appfw.inc
index 2f3effce6..07b958aea 100644
--- a/meta-app-framework/recipes-devtools/run-postinsts/run-postinsts_appfw.inc
+++ b/meta-app-framework/recipes-devtools/run-postinsts/run-postinsts_appfw.inc
@@ -1,14 +1,14 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/run-postinsts:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/run-postinsts:"
-SRC_URI_append = " file://ldconfig-wait.conf"
+SRC_URI:append = " file://ldconfig-wait.conf"
-do_configure_append() {
+do_configure:append() {
if ! grep -q StandardOutput= ${WORKDIR}/run-postinsts.service; then
sed -i '/ExecStart=/iStandardOutput=journal+console' ${WORKDIR}/run-postinsts.service
fi
}
-do_install_append() {
+do_install:append() {
install -d ${D}${sysconfdir}/systemd/system/run-postinsts.service.d
install -m 0644 ${WORKDIR}/ldconfig-wait.conf ${D}${sysconfdir}/systemd/system/run-postinsts.service.d
}