summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-example/afb-client/afb-client_1.0.bb
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2016-06-23 16:00:59 +0000
committerStephane Desneux <stephane.desneux@iot.bzh>2017-03-27 15:33:39 +0200
commit1ac5c704bb4b7fd72d9e382ccf23f4d186da0f86 (patch)
treef5df879594fb92d3c02c05ed240cbcfcc0e70c39 /meta-app-framework/recipes-example/afb-client/afb-client_1.0.bb
parent5875cc45a671b1a3e7671ec84ec6ebb1ab17696a (diff)
add layer meta-app-framework
meta-app-framework is a layer containing the AGL App Framework recipes 4 new layers are added for application framework: * meta-intel-iot-security/meta-security-smack * meta-intel-iot-security/meta-security-framework * meta-agl/meta-agl-security * meta-agl/meta-app-framework Configuration file changes to support AppFw: * activation of Smack and Cynara * modify the tar command to be used to support Smack extended attributes Change-Id: Idc8abdc8869787feb4b534ee45bf7b5d3dde3632 Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
Diffstat (limited to 'meta-app-framework/recipes-example/afb-client/afb-client_1.0.bb')
-rw-r--r--meta-app-framework/recipes-example/afb-client/afb-client_1.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-app-framework/recipes-example/afb-client/afb-client_1.0.bb b/meta-app-framework/recipes-example/afb-client/afb-client_1.0.bb
new file mode 100644
index 000000000..54a8216c4
--- /dev/null
+++ b/meta-app-framework/recipes-example/afb-client/afb-client_1.0.bb
@@ -0,0 +1,29 @@
+SUMMARY = "HTML5 demo template for AFB"
+DESCRIPTION = "afb-client is a sample AngularJS/HTML5 application using \
+Application Framework Binder with token plugin."
+HOMEPAGE = "http://www.iot.bzh"
+
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6cb04bdb88e11107e3af4d8e3f301be5"
+
+#DEPENDS = "nodejs-native"
+RDEPENDS_${PN} = "af-binder af-binder-plugin-authlogin"
+
+SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-demo;protocol=https;branch=1.0"
+SRC_URI_files = "file://afb-client \
+ "
+SRC_URI = "${SRC_URI_git} \
+ ${SRC_URI_files} \
+ "
+SRCREV = "9e9b459fa27d7a359a060024c9639b99b45813d5"
+S = "${WORKDIR}/git/afb-client"
+
+do_install () {
+ mkdir -p ${D}/${datadir}/agl/afb-client
+ cp -ra ${S}/dist.prod/* ${D}/${datadir}/agl/afb-client/
+
+ mkdir -p ${D}/${bindir}
+ install -m 0755 ${WORKDIR}/afb-client ${D}/${bindir}/afb-client
+}
+
+FILES_${PN} += "${datadir}"