summaryrefslogtreecommitdiffstats
path: root/meta-app-framework
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2019-06-11 22:58:40 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-06-19 13:05:28 +0000
commit8655b9d299af00bf771c59b9f22ff48119897377 (patch)
tree231d27164ac43af8278d1a490946d8e79fffe2d6 /meta-app-framework
parent9d9c024ba9de04965aff3e0e2e8caa2abb80ab7c (diff)
af-platform-setup: Add recipe for setting platform
The Application Framework has implications on platform setup. This commit introduces a recipe that at the end would group all these required setup at on place. Bug-AGL: SPEC-1015 Change-Id: I45904ba269883329295bcbc3c70427edbfdd674f Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'meta-app-framework')
-rw-r--r--meta-app-framework/recipes-core/af-platform-setup/af-platform-setup_1.0.bb16
-rw-r--r--meta-app-framework/recipes-core/af-platform-setup/files/udev-shared.conf4
-rw-r--r--meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb1
3 files changed, 21 insertions, 0 deletions
diff --git a/meta-app-framework/recipes-core/af-platform-setup/af-platform-setup_1.0.bb b/meta-app-framework/recipes-core/af-platform-setup/af-platform-setup_1.0.bb
new file mode 100644
index 000000000..0963875d1
--- /dev/null
+++ b/meta-app-framework/recipes-core/af-platform-setup/af-platform-setup_1.0.bb
@@ -0,0 +1,16 @@
+HOMEPAGE = "here"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "file://udev-shared.conf"
+
+S = "${WORKDIR}"
+
+do_install() {
+ d=${D}${systemd_system_unitdir}/systemd-udevd.service.d
+ install -d $d
+ install ${S}/udev-shared.conf $d
+}
+
+FILES_${PN} = "${systemd_system_unitdir}"
diff --git a/meta-app-framework/recipes-core/af-platform-setup/files/udev-shared.conf b/meta-app-framework/recipes-core/af-platform-setup/files/udev-shared.conf
new file mode 100644
index 000000000..cce02bc58
--- /dev/null
+++ b/meta-app-framework/recipes-core/af-platform-setup/files/udev-shared.conf
@@ -0,0 +1,4 @@
+[Service]
+ExecStartPre=/bin/mkdir -p /run/udev
+ExecStartPre=/usr/bin/chsmack -r -a System::Shared -t /run/udev
+
diff --git a/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb b/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb
index 3944c1915..854835d4c 100644
--- a/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb
+++ b/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb
@@ -16,4 +16,5 @@ RDEPENDS_${PN} += "\
af-main \
nss-localuser \
systemd-agl-sync \
+ af-platform-setup \
"