summaryrefslogtreecommitdiffstats
path: root/meta-ivi-common/recipes-extended
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-09-01 23:22:37 +0200
committerGerrit Code Review <gerrit@172.30.200.200>2016-09-01 22:42:01 +0000
commit85844f4d250d1a45129455c76e467e38d3b3e92c (patch)
treeeae6ed37b93870ea9d839834c0bfede384882331 /meta-ivi-common/recipes-extended
parentbcd5d1e36b83d39ea57ffa8b271a2256eaed49ff (diff)
Changes for building with YP 2.1.1 'krogoth'
Notable changes: - Update poky-agl.conf for YP 2.1 krogoth - change mesa bbappend to mesa_11 - TODO: check need for gallium, or replace with DRM see SPEC-237 - remote linux-yocto_3.14 as it is no longer shipped with YP 2.1 - rtl-sdr got a fix included for its packageconfig file - update 0001-disable-when-booting-over-nfs.patch - update checksums for ft2demo - TODO: check installation of test binaries - automotive-message-broker needed a workaround in the recipe - TODO: fix package and recipe - wayland-ivi-extension fix for use of autotools _AND_ cmake at the same time: only use cmake - port pulseaudio_6.0.bbappend to pulseaudio_8.0.bbappend - TODO: check patches and forward-port - agl-audio-plugin is currently disabled until ported to pulseaudio 8.0 - gstreamer1.0_1.2.3 is only used by meta-renesas, thus move it there - update dlt-daemon to 2.15 TODO: - check values in poky-agl.conf - check mesa for needed bbappends on other boards (tested qemux86 and qemux86_64) - check pulsaudio bbappend and forward-port patches (patches disabled!) - check agl-audio-plugin and forward-port (build disabled!) - check freetype bbappend wrt. installation path of test binaries - check automotive-message-broker wrt installation routines for libraries (QA failure) - check wayland-ivi-extension build and capabilities Change-Id: I553e03cc37348cba2fc4a022820157c78bb184d3 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-ivi-common/recipes-extended')
-rw-r--r--meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0002-Don-t-execute-processes-as-a-specific-user.patch78
-rw-r--r--meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0004-Modify-systemd-config-directory.patch25
-rw-r--r--meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon_2.15.0.bb42
3 files changed, 87 insertions, 58 deletions
diff --git a/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0002-Don-t-execute-processes-as-a-specific-user.patch b/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0002-Don-t-execute-processes-as-a-specific-user.patch
index 40c5afbeb..168847990 100644
--- a/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0002-Don-t-execute-processes-as-a-specific-user.patch
+++ b/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0002-Don-t-execute-processes-as-a-specific-user.patch
@@ -7,85 +7,75 @@ Upstream-Status: Inappropriate [Configuration Specific]
Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com>
---
systemd/dlt-adaptor-udp.service.cmake | 1 -
- systemd/dlt-dbus.service.cmake | 1 -
systemd/dlt-example-user.service.cmake | 1 -
systemd/dlt-receive.service.cmake | 1 -
systemd/dlt-system.service.cmake | 1 -
systemd/dlt.service.cmake | 1 -
- 6 files changed, 6 deletions(-)
+ 5 files changed, 5 deletions(-)
diff --git a/systemd/dlt-adaptor-udp.service.cmake b/systemd/dlt-adaptor-udp.service.cmake
-index 0c39637..f446757 100644
+index 8dac1f2..ecf9f9e 100644
--- a/systemd/dlt-adaptor-udp.service.cmake
+++ b/systemd/dlt-adaptor-udp.service.cmake
-@@ -20,7 +20,6 @@ Wants=dlt.service
+@@ -21,9 +21,8 @@ Wants=dlt.service
[Service]
- Type=Simple
--User=genivi
+ Type=simple
+-User=@DLT_USER@
ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-adaptor-udp -a @DLT_ADAPTOR_UDP_APPID@ -c @DLT_ADAPTOR_UDP_CTID@ -p @DLT_ADAPTOR_UDP_PORT@
LimitCORE=infinity
-diff --git a/systemd/dlt-dbus.service.cmake b/systemd/dlt-dbus.service.cmake
-index 2727c2d..d1e3b12 100755
---- a/systemd/dlt-dbus.service.cmake
-+++ b/systemd/dlt-dbus.service.cmake
-@@ -21,7 +21,6 @@ Wants=dlt.service
-
- [Service]
- Type=Simple
--User=root
- ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-dbus
- WatchdogSec=@DLT_WatchdogSec@
- NotifyAccess=main
+ [Install]
+-WantedBy=multi-user.target
+\ No newline at end of file
++WantedBy=multi-user.target
diff --git a/systemd/dlt-example-user.service.cmake b/systemd/dlt-example-user.service.cmake
-index 3652292..b67a83c 100644
+index b665742..35009b0 100644
--- a/systemd/dlt-example-user.service.cmake
+++ b/systemd/dlt-example-user.service.cmake
-@@ -20,6 +20,5 @@ Wants=dlt.service
+@@ -21,6 +21,5 @@ Wants=dlt.service
[Service]
- Type=Simple
--User=genivi
+ Type=simple
+-User=@DLT_USER@
ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-example-user "Hallo from GENIVI DLT example user application"
- LimitCORE=infinity
+-LimitCORE=infinity
\ No newline at end of file
++LimitCORE=infinity
diff --git a/systemd/dlt-receive.service.cmake b/systemd/dlt-receive.service.cmake
-index b92c8b2..4bbdfc2 100644
+index c07d447..8f88f00 100644
--- a/systemd/dlt-receive.service.cmake
+++ b/systemd/dlt-receive.service.cmake
-@@ -21,6 +21,5 @@ Wants=dlt.service
+@@ -22,6 +22,5 @@ Wants=dlt.service
[Service]
- Type=Simple
--User=genivi
+ Type=simple
+-User=@DLT_USER@
ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-receive -o /tmp/dlt_receive_log.dlt localhost
- LimitCORE=infinity
+-LimitCORE=infinity
\ No newline at end of file
++LimitCORE=infinity
diff --git a/systemd/dlt-system.service.cmake b/systemd/dlt-system.service.cmake
-index f5e844b..7ec995c 100755
+index 0e91f42..1a5b913 100755
--- a/systemd/dlt-system.service.cmake
+++ b/systemd/dlt-system.service.cmake
-@@ -21,7 +21,6 @@ Wants=dlt.service
-
- [Service]
- Type=Simple
--User=genivi
- ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-system
- WatchdogSec=@DLT_WatchdogSec@
- NotifyAccess=main
+@@ -22,7 +22,6 @@ Wants=dlt.service
+
+ [Service]
+ Type=simple
+-User=@DLT_USER@
+ ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-system
+ WatchdogSec=@DLT_WatchdogSec@
+ NotifyAccess=main
diff --git a/systemd/dlt.service.cmake b/systemd/dlt.service.cmake
-index 22279c4..7bb05bc 100755
+index 0b3ee2c..e4753a2 100755
--- a/systemd/dlt.service.cmake
+++ b/systemd/dlt.service.cmake
-@@ -20,7 +20,6 @@ Documentation=man:dlt-daemon(1) man:dlt.conf(5)
+@@ -21,7 +21,6 @@ Documentation=man:dlt-daemon(1) man:dlt.conf(5)
[Service]
- Type=Simple
--User=genivi
+ Type=simple
+-User=@DLT_USER@
ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-daemon
WatchdogSec=@DLT_WatchdogSec@
NotifyAccess=main
---
-1.9.3
-
diff --git a/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0004-Modify-systemd-config-directory.patch b/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0004-Modify-systemd-config-directory.patch
index df762f33d..685dfcddc 100644
--- a/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0004-Modify-systemd-config-directory.patch
+++ b/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0004-Modify-systemd-config-directory.patch
@@ -9,19 +9,16 @@ Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com>
systemd/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/systemd/CMakeLists.txt b/systemd/CMakeLists.txt
-index a9838e4..c8feae5 100644
---- a/systemd/CMakeLists.txt
-+++ b/systemd/CMakeLists.txt
-@@ -16,7 +16,7 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e6b44a2..0e885bf 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -175,7 +175,7 @@ if(WITH_SYSTEMD OR WITH_SYSTEMD_WATCHDOG OR WITH_SYSTEMD_JOURNAL)
- if(WITH_SYSTEMD)
+ set( systemd_SRCS ${CMAKE_SOURCE_DIR}/systemd/3rdparty/sd-daemon.c)
-- set(SYSTEMD_CONFIGURATIONS_FILES_DIR ${CMAKE_INSTALL_PREFIX}/lib/systemd/system )
-+ set(SYSTEMD_CONFIGURATIONS_FILES_DIR /lib/systemd/system )
-
- if(WITH_SYSTEMD_WATCHDOG)
- set( DLT_WatchdogSec 2 )
---
-1.9.3
-
+- set(SYSTEMD_UNITDIR "${CMAKE_INSTALL_PREFIX}/lib/systemd/system" CACHE PATH
++ set(SYSTEMD_UNITDIR "/lib/systemd/system" CACHE PATH
+ "Set directory to install systemd unit files")
+
+ add_subdirectory( systemd )
diff --git a/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon_2.15.0.bb b/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon_2.15.0.bb
new file mode 100644
index 000000000..8ab95d1ec
--- /dev/null
+++ b/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon_2.15.0.bb
@@ -0,0 +1,42 @@
+SUMMARY = "Diagnostic Log and Trace"
+DESCRIPTION = "This component provides a standardised log and trace interface, \
+based on the standardised protocol specified in the AUTOSAR standard 4.0 DLT. \
+This component can be used by GENIVI components and other applications as \
+logging facility providing: \
+- the DLT shared library \
+- the DLT daemon, including startup scripts \
+- the DLT daemon adaptors- the DLT client console utilities \
+- the DLT test applications"
+HOMEPAGE = "https://www.genivi.org/"
+SECTION = "console/utils"
+LICENSE = "MPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8184208060df880fe3137b93eb88aeea"
+
+DEPENDS = "dbus zlib"
+
+SRCREV = "e9a486a08fff6d3cc7133a350cec3ee10f463207"
+SRC_URI = "git://git.projects.genivi.org/${BPN}.git;protocol=http \
+ file://0002-Don-t-execute-processes-as-a-specific-user.patch \
+ file://0004-Modify-systemd-config-directory.patch \
+ "
+S = "${WORKDIR}/git"
+
+inherit gzipnative autotools gettext cmake systemd
+
+PACKAGES += "${PN}-systemd"
+SYSTEMD_PACKAGES = "${PN} ${PN}-systemd"
+SYSTEMD_SERVICE_${PN} = "dlt-system.service dlt.service"
+SYSTEMD_AUTO_ENABLE_${PN} = "enable"
+SYSTEMD_SERVICE_${PN}-systemd = "dlt-example-user.service \
+ dlt-dbus.service \
+ dlt-adaptor-udp.service \
+ dlt-receive.service"
+SYSTEMD_AUTO_ENABLE_${PN}-systemd = "disable"
+
+EXTRA_OECMAKE = "-DWITH_SYSTEMD=ON"
+
+FILES_${PN}-doc += "/usr/share/dlt-filetransfer"
+
+do_install_append() {
+ rm -f ${D}${bindir}/dlt-test-*
+}