summaryrefslogtreecommitdiffstats
path: root/meta-ivi-common
diff options
context:
space:
mode:
authorWalt Miner <wminer@linuxfoundation.org>2015-10-23 15:01:16 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2015-10-23 15:01:16 +0000
commitec84dcf85012b9dd07fa2300a46865ad4cdafa0d (patch)
tree60db10955075c5b834c6aef966830d609727a42f /meta-ivi-common
parenteb235a0b1f2c8a80e54670eb544d897eb605954a (diff)
parent9201dffde9bf2fefb53c4bee6470c8407bda2b34 (diff)
Merge "Provide Wayland FITS, disabled by default"
Diffstat (limited to 'meta-ivi-common')
-rw-r--r--meta-ivi-common/recipes-test/wayland/wayland-fits_%.bbappend5
-rw-r--r--meta-ivi-common/recipes-test/wayland/wayland-fits_git.bb33
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-ivi-common/recipes-test/wayland/wayland-fits_%.bbappend b/meta-ivi-common/recipes-test/wayland/wayland-fits_%.bbappend
new file mode 100644
index 000000000..772f81b0f
--- /dev/null
+++ b/meta-ivi-common/recipes-test/wayland/wayland-fits_%.bbappend
@@ -0,0 +1,5 @@
+# Disable GTK+ and EFL tests
+PACKAGECONFIG = ""
+
+# UInput driver is necessary on QEMU
+RDEPENDS_${PN}_append_qemux86-64 = " kernel-module-uinput"
diff --git a/meta-ivi-common/recipes-test/wayland/wayland-fits_git.bb b/meta-ivi-common/recipes-test/wayland/wayland-fits_git.bb
new file mode 100644
index 000000000..3a4f8a2ca
--- /dev/null
+++ b/meta-ivi-common/recipes-test/wayland/wayland-fits_git.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Wayland-fits, the Wayland Functional Integration Test Suite"
+DESCRIPTION = "Wayland-fits is a fully automated functional integration \
+test suite. Its main purpose is to test the functionality and integration of \
+client-side (i.e. toolkit) and server-side (compositor) implementations of \
+the Wayland protocol."
+HOMEPAGE = "https://github.com/01org/wayland-fits"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f8d34cadaf891753c0f00c6cd48f08f5 \
+ file://src/extensions/weston/weston-wfits.cpp;endline=21;md5=848c81e55cf3a30a9f6ed75f0dba7a97"
+
+SRC_URI = "git://github.com/01org/wayland-fits.git"
+SRCREV = "f30dfa9fceb438d3687c5215093fffc21a7852fc"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+DEPENDS = "libcheck boost wayland weston"
+RDEPENDS_${PN} = "weston"
+
+EXTRA_OECONF += "--enable-shared --disable-static --with-boost-libdir=${STAGING_LIBDIR}"
+
+PACKAGECONFIG ??= "elementary gtk+3"
+
+PACKAGECONFIG[elementary] = "--enable-efl-tests,--disable-efl-tests,elementary"
+PACKAGECONFIG[gtk+3] = "--enable-gtk-tests,--disable-gtk-tests,gtk+3"
+
+do_install_append() {
+ rm -f ${D}/${libdir}/weston/*.la
+}
+
+FILES_${PN} += "${bindir}/wfits ${libdir}/weston/*.so"
+FILES_${PN}-dbg += "${bindir}/.debug ${libdir}/weston/.debug ${prefix}/src"