summaryrefslogtreecommitdiffstats
path: root/meta-netboot/recipes-core/systemd/resolv-conf-relabel.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-23 07:37:25 -0400
committerjenkins-dontreply@build.automotivelinux.org <collab-it+agl-jobbuilder@linuxfoundation.org>2024-07-01 09:00:21 +0000
commitabc4af58a1a306ab5b1597bb30815b2548dd778c (patch)
tree5d06c9050cf49e14456706e244d695d6e20a24e6 /meta-netboot/recipes-core/systemd/resolv-conf-relabel.bb
parentee69cf9961b97df1b9b5bed167d285e51d6d1625 (diff)
Update recipes for transition to UNPACKDIR
Update recipes to handle the transition to using UNPACKDIR as the destination for unpacked files. For recipes that had been using S = WORKDIR, the approach used in meta-openembedded has been followed, i.e. using UNPACKDIR in tasks for consistency. Bug-AGL: SPEC-5147 Change-Id: I32e277e15e5aa1ac93dadc67199dedd148d3d0b9 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-netboot/recipes-core/systemd/resolv-conf-relabel.bb')
-rw-r--r--meta-netboot/recipes-core/systemd/resolv-conf-relabel.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-netboot/recipes-core/systemd/resolv-conf-relabel.bb b/meta-netboot/recipes-core/systemd/resolv-conf-relabel.bb
index 36d096b44..6180b78c2 100644
--- a/meta-netboot/recipes-core/systemd/resolv-conf-relabel.bb
+++ b/meta-netboot/recipes-core/systemd/resolv-conf-relabel.bb
@@ -4,6 +4,9 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
SRC_URI = "file://resolv-conf-relabel.service"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
inherit systemd allarch features_check
SYSTEMD_SERVICE:${PN} = "${BPN}.service"
@@ -15,7 +18,7 @@ do_compile[noexec] = "1"
do_install() {
install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/resolv-conf-relabel.service ${D}${systemd_system_unitdir}/
+ install -m 0644 ${UNPACKDIR}/resolv-conf-relabel.service ${D}${systemd_system_unitdir}/
}
FILES:${PN} += "${systemd_system_unitdir}"