summaryrefslogtreecommitdiffstats
path: root/meta-netboot
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2016-06-08 15:31:21 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2016-06-19 19:25:27 +0000
commit49f929e35a8fe1a3c7353ce6bd62b2158e4e9493 (patch)
tree821af930162f0371d66bf1f88f6db3427cca9039 /meta-netboot
parentd96d6bdc5399ab257e482248682c6d90dac7d9ae (diff)
meta-netboot: enable NBD and Ramdisk support in kernel config
NBD and Ramdisk support are required in the kernel to have the root filesystem mounted as an NBD device: * ramdisk is required to load the initrd (not an initramfs) * NBD is required to mount the root device from a remote NBD server Change-Id: Ib726714adfb549eaeb21f96e7bf874290e700a8b Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
Diffstat (limited to 'meta-netboot')
-rw-r--r--meta-netboot/recipes-kernel/linux/files/nbd.cfg1
-rw-r--r--meta-netboot/recipes-kernel/linux/files/ramdisk.cfg1
-rw-r--r--meta-netboot/recipes-kernel/linux/linux-yocto_%.bbappend6
3 files changed, 8 insertions, 0 deletions
diff --git a/meta-netboot/recipes-kernel/linux/files/nbd.cfg b/meta-netboot/recipes-kernel/linux/files/nbd.cfg
new file mode 100644
index 000000000..af37685e4
--- /dev/null
+++ b/meta-netboot/recipes-kernel/linux/files/nbd.cfg
@@ -0,0 +1 @@
+CONFIG_BLK_DEV_NBD=y
diff --git a/meta-netboot/recipes-kernel/linux/files/ramdisk.cfg b/meta-netboot/recipes-kernel/linux/files/ramdisk.cfg
new file mode 100644
index 000000000..41530dd6e
--- /dev/null
+++ b/meta-netboot/recipes-kernel/linux/files/ramdisk.cfg
@@ -0,0 +1 @@
+CONFIG_BLK_DEV_RAM=y
diff --git a/meta-netboot/recipes-kernel/linux/linux-yocto_%.bbappend b/meta-netboot/recipes-kernel/linux/linux-yocto_%.bbappend
new file mode 100644
index 000000000..88f244122
--- /dev/null
+++ b/meta-netboot/recipes-kernel/linux/linux-yocto_%.bbappend
@@ -0,0 +1,6 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+# Extra configuration options for NBD support and netboot over RAMFS
+SRC_URI += "file://nbd.cfg \
+ file://ramdisk.cfg \
+ "