summaryrefslogtreecommitdiffstats
path: root/meta-netboot
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-02-22 07:54:38 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-02-22 07:54:38 +0100
commit72d14f16bf3e16f977e483446dbac2c92fd0f68a (patch)
tree624a2d9403015eb0f60ed399b19792e8448a75a8 /meta-netboot
parent4ee20546bf7754da6525bf27bfc6f9aa8f56ce69 (diff)
Hotfix for db410 on rocko
The db410c build uses IMAGE_FSTYPES_append which is a bad idea and should be changed to IMAGE_FSTYPES ?= Anyway - add a hotfix directly in the recipes. Change-Id: I163e4fdccfc890085cf98571dcf5d7bf21cffadd Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-netboot')
-rw-r--r--meta-netboot/recipes-core/images/initramfs-netboot-image.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-netboot/recipes-core/images/initramfs-netboot-image.bb b/meta-netboot/recipes-core/images/initramfs-netboot-image.bb
index cc6bc6753..965a0bd37 100644
--- a/meta-netboot/recipes-core/images/initramfs-netboot-image.bb
+++ b/meta-netboot/recipes-core/images/initramfs-netboot-image.bb
@@ -11,9 +11,12 @@ IMAGE_LINGUAS = ""
LICENSE = "MIT"
-IMAGE_FSTYPES = "${NETBOOT_FSTYPES}"
+IMAGE_FSTYPES := "${NETBOOT_FSTYPES}"
inherit core-image
+# hotfix for dragonboard (which uses _append in the bsp)
+IMAGE_FSTYPES_remove += "wic.gz"
+
IMAGE_ROOTFS_SIZE = "8192"
IMAGE_ROOTFS_EXTRA_SPACE = "256"