summaryrefslogtreecommitdiffstats
path: root/meta-netboot
diff options
context:
space:
mode:
authorTom Rini <trini@konsulko.com>2017-11-03 15:29:15 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-11-22 10:07:25 +0000
commit9691b89fd8a0014b7d57c9fc35cf75bfe8da1577 (patch)
tree0cbc41ae0a0c0d4a38e5952f4678c0831fbe6cb7 /meta-netboot
parent5692de99c4e04d51a6c5da86fea1710d55420873 (diff)
Rework Linux Kernel fragment applications
- All kernel recipes must inherit linux-agl.inc - All kernel recipes for a given version (e.g. 4.9) should include linux-VER-agl.inc in order to avoid duplication (such as the SMACK label patch or security fixes) - We enforce having merge_config.sh be invoked at the end, in order to make sure fragments will be applied. - Add a new fragment for Raspberry Pi to ensure the Pi Touchscreen is still enabled. With all of the above, we fix a number of minor issues as well, such as platforms manually enabling NBD/RAMDISK for netboot as the previous logic was not working in all cases. Bug-AGL: SPEC-946 Change-Id: Ic688e899df5861d83712af12d8e1c6c3c9643300 Signed-off-by: Tom Rini <trini@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/12063 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: José Bollo <jobol@nonadev.net> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-netboot')
-rw-r--r--meta-netboot/recipes-kernel/linux/files/nbd.cfg1
-rw-r--r--meta-netboot/recipes-kernel/linux/files/ramdisk.cfg1
-rw-r--r--meta-netboot/recipes-kernel/linux/linux-yocto_%.bbappend6
3 files changed, 0 insertions, 8 deletions
diff --git a/meta-netboot/recipes-kernel/linux/files/nbd.cfg b/meta-netboot/recipes-kernel/linux/files/nbd.cfg
deleted file mode 100644
index af37685e4..000000000
--- a/meta-netboot/recipes-kernel/linux/files/nbd.cfg
+++ /dev/null
@@ -1 +0,0 @@
-CONFIG_BLK_DEV_NBD=y
diff --git a/meta-netboot/recipes-kernel/linux/files/ramdisk.cfg b/meta-netboot/recipes-kernel/linux/files/ramdisk.cfg
deleted file mode 100644
index 41530dd6e..000000000
--- a/meta-netboot/recipes-kernel/linux/files/ramdisk.cfg
+++ /dev/null
@@ -1 +0,0 @@
-CONFIG_BLK_DEV_RAM=y
diff --git a/meta-netboot/recipes-kernel/linux/linux-yocto_%.bbappend b/meta-netboot/recipes-kernel/linux/linux-yocto_%.bbappend
deleted file mode 100644
index f20d57a22..000000000
--- a/meta-netboot/recipes-kernel/linux/linux-yocto_%.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-
-# Extra configuration options for NBD support and netboot over RAMFS
-SRC_URI_append = " file://nbd.cfg \
- file://ramdisk.cfg \
- "