summaryrefslogtreecommitdiffstats
path: root/meta-netboot
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-02 17:10:51 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-08-23 11:56:42 +0000
commitdd6fc5dcaa0a027b7651bb365d5dd0f623498f8f (patch)
tree428562251f7033e4d44c848e7258243fb9421a94 /meta-netboot
parent756165e01db655cdbd2788eb134fba79fea7fd90 (diff)
Convert to new override syntax
This is mostly the result of running a slightly customized version of the convert-overrides.py script from poky with additional overrides added. A few minor fixups were done by hand afterwards during a review of the changes. The intent of these changes is to minimize the effort to keep the "next" branch that builds against poky master up to date and tested in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4052 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ia3bf63b7cb1aa1d95ada373d1a3ab56def0a125d Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26564 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-netboot')
-rw-r--r--meta-netboot/conf/include/agl-netboot.inc2
-rw-r--r--meta-netboot/recipes-core/busybox/busybox_netboot.inc4
-rw-r--r--meta-netboot/recipes-core/images/initramfs-netboot-image_netboot.inc2
-rw-r--r--meta-netboot/recipes-core/initramfs-netboot/initramfs-netboot_1.0.bb4
-rw-r--r--meta-netboot/recipes-support/nbd/nbd_netboot.inc4
-rwxr-xr-xmeta-netboot/scripts/run-yocto-check-layer-flags-enabled.sh4
-rwxr-xr-xmeta-netboot/scripts/run-yocto-check-layer.sh4
7 files changed, 12 insertions, 12 deletions
diff --git a/meta-netboot/conf/include/agl-netboot.inc b/meta-netboot/conf/include/agl-netboot.inc
index 03f8ed533..555629537 100644
--- a/meta-netboot/conf/include/agl-netboot.inc
+++ b/meta-netboot/conf/include/agl-netboot.inc
@@ -1,3 +1,3 @@
INHERIT += "netboot"
-IMAGE_INSTALL_append_netboot = " curl"
+IMAGE_INSTALL:append:netboot = " curl"
diff --git a/meta-netboot/recipes-core/busybox/busybox_netboot.inc b/meta-netboot/recipes-core/busybox/busybox_netboot.inc
index 0bcd5afa5..836493834 100644
--- a/meta-netboot/recipes-core/busybox/busybox_netboot.inc
+++ b/meta-netboot/recipes-core/busybox/busybox_netboot.inc
@@ -1,6 +1,6 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-SRC_URI_append = " \
+SRC_URI:append = " \
file://enable_nbd.cfg \
"
diff --git a/meta-netboot/recipes-core/images/initramfs-netboot-image_netboot.inc b/meta-netboot/recipes-core/images/initramfs-netboot-image_netboot.inc
index 0c97b0f93..b98024de6 100644
--- a/meta-netboot/recipes-core/images/initramfs-netboot-image_netboot.inc
+++ b/meta-netboot/recipes-core/images/initramfs-netboot-image_netboot.inc
@@ -15,7 +15,7 @@ IMAGE_FSTYPES := "${NETBOOT_FSTYPES}"
inherit core-image
# hotfix for dragonboard (which uses _append in the bsp)
-IMAGE_FSTYPES_remove = "wic.gz"
+IMAGE_FSTYPES:remove = "wic.gz"
IMAGE_ROOTFS_SIZE = "8192"
IMAGE_ROOTFS_EXTRA_SPACE = "256"
diff --git a/meta-netboot/recipes-core/initramfs-netboot/initramfs-netboot_1.0.bb b/meta-netboot/recipes-core/initramfs-netboot/initramfs-netboot_1.0.bb
index f519694ed..264b21492 100644
--- a/meta-netboot/recipes-core/initramfs-netboot/initramfs-netboot_1.0.bb
+++ b/meta-netboot/recipes-core/initramfs-netboot/initramfs-netboot_1.0.bb
@@ -5,7 +5,7 @@ SRC_URI = "file://init.sh"
S = "${WORKDIR}"
-RDEPENDS_${PN} += "nbd-client"
+RDEPENDS:${PN} += "nbd-client"
do_install() {
install -dm 0755 ${D}/etc
@@ -17,5 +17,5 @@ do_install() {
inherit allarch
-FILES_${PN} += " /dev /etc/initrd-release /sbin/init "
+FILES:${PN} += " /dev /etc/initrd-release /sbin/init "
diff --git a/meta-netboot/recipes-support/nbd/nbd_netboot.inc b/meta-netboot/recipes-support/nbd/nbd_netboot.inc
index f2286616f..4c9489de1 100644
--- a/meta-netboot/recipes-support/nbd/nbd_netboot.inc
+++ b/meta-netboot/recipes-support/nbd/nbd_netboot.inc
@@ -1,5 +1,5 @@
-do_install_append() {
+do_install:append() {
mv ${D}/${sbindir}/nbd-client ${D}/${sbindir}/nbd3-client
}
-FILES_${PN}-client_append = " ${sbindir}/nbd3-client"
+FILES:${PN}-client:append = " ${sbindir}/nbd3-client"
diff --git a/meta-netboot/scripts/run-yocto-check-layer-flags-enabled.sh b/meta-netboot/scripts/run-yocto-check-layer-flags-enabled.sh
index c64afa714..cf7a75a30 100755
--- a/meta-netboot/scripts/run-yocto-check-layer-flags-enabled.sh
+++ b/meta-netboot/scripts/run-yocto-check-layer-flags-enabled.sh
@@ -20,8 +20,8 @@ AGL_EXTRA_IMAGE_FSTYPES ?= ""
# important settings imported from poky-agl.conf
# we do not import
-DISTRO_FEATURES_append = " systemd smack"
-DISTRO_FEATURES_BACKFILL_CONSIDERED_append = " sysvinit"
+DISTRO_FEATURES:append = " systemd smack"
+DISTRO_FEATURES_BACKFILL_CONSIDERED:append = " sysvinit"
VIRTUAL-RUNTIME_init_manager = "systemd"
# workaround
diff --git a/meta-netboot/scripts/run-yocto-check-layer.sh b/meta-netboot/scripts/run-yocto-check-layer.sh
index b3b8e08e1..09e655afb 100755
--- a/meta-netboot/scripts/run-yocto-check-layer.sh
+++ b/meta-netboot/scripts/run-yocto-check-layer.sh
@@ -20,8 +20,8 @@ AGL_EXTRA_IMAGE_FSTYPES ?= ""
# important settings imported from poky-agl.conf
# we do not import
-DISTRO_FEATURES_append = " systemd smack"
-DISTRO_FEATURES_BACKFILL_CONSIDERED_append = " sysvinit"
+DISTRO_FEATURES:append = " systemd smack"
+DISTRO_FEATURES_BACKFILL_CONSIDERED:append = " sysvinit"
VIRTUAL-RUNTIME_init_manager = "systemd"
# workaround